iPhone 5 can't connect to WPA 2 network

Discussion in 'iPhone' started by mnsportsgeek, Sep 21, 2012.

  1. mnsportsgeek macrumors 65816

    Joined:
    Feb 24, 2009
    #1
    Hello all,

    Curious to see if this is a widespread issue or a hardware issue with my phone. I purchased a white 64gb AT&T iPhone 5 today. I was at school this afternoon and I noticed that my phone would not load web pages when connected to the secured (WPA2) wireless network but it would load web pages when connected to the school's unsecured guest network. I thought, "maybe it's just a problem with my school's network today." Nope, came home and while I can connect and receive an IP address on the WPA 2 encrypted network at my house, i cannot load a web page for the life of me.

    I'm curious to see if other's are having this problem (software issue) or if it's just me (hardware issue needing replacement).

    Other experiences appreciated!
     
  2. turn1racing macrumors newbie

    Joined:
    Sep 21, 2012
    #2
    I'm able to connect to mine (netgear router). When I first set up the phone, it didn't want to connect at all. I clicked the network again and it worked. Haven't had any issues with it since.
     
  3. AlPlPlLE macrumors regular

    Joined:
    Jan 10, 2012
    #3
    Just out of curiously, try to connect to it WPA instead of WPA2
     
  4. Kadman macrumors 65816

    Kadman

    Joined:
    Sep 22, 2007
    #4
    WPA2 here with no issue. i'm running a pair of Linksys E3000 routers with DD-WRT firmware.
     
  5. superfox247 macrumors newbie

    Joined:
    Oct 7, 2012
    #6
    Hi All,

    Like to share with you my findings and resolution with the iPhone 5 Wi-Fi slow and unusable connection when using WPA, WPA2. I work as Network engineer and also hold a Cisco CCNP and other security qualifications. Hopefully this might resolve and help some people out.

    After experiencing unusable Wi-Fi on various networks with lots of network timeouts on my new IPhone 5 16GB Black I downloaded an app that allows you to ping from iPhone/iPad I used a paid app called Scany but there are lots of free apps that allow you to ping.

    What I discovered testing with my own wireless N access point 802.11n:

    From my iPhone 5 I ran a continuous ping of around 500 packets to my wireless N access point IP address.. Remember we are testing the Wi-Fi connection so don’t add complications of pinging across the internet which could introduce issues and latency out of your control.

    No Security – No Issues
    WEP Security – No Issues
    WPA with TKIP encryption - No Issues
    WPA2 with TKIP encryption - No Issues
    WPA with AES encryption – Approx. 70+% packet loss
    WPA2 with AES encryption - Approx. 70+% packet loss

    I used 2.4Ghz range and 5Ghz range. Same on both frequencies.

    So the issue I suffered and I suspect most people are suffering is down to WPA2 or WPA with AES encryption. If you can change to TKIP. I would not recommend selecting Automatic encryption as it is most likely to select AES as it is preferred encryption standard.

    Note WPA2 or WPA with TKIP encryption is very secure and should not really cause any real security concerns. AES is more secure though. The main difference you will notice though if you are using a wireless N Wi-Fi network is that TKIP will only allow data to pass at a theoretical speed of 54Mbits the same as a Wireless G network 802.11g

    I suspect most people connect to various secured Wi-Fi networks during our daily lives you would have no way of knowing or altering the security used or encryption in use. Most Wi-Fi networks I would imagine are WPA2 or WPA with AES encryption as this is the most secure standard you are likely suffer this problem.

    Don’t turn wireless off and I certainly cannot recommend using WEP as it is easily compromised.

    As there is no major stories in the media although growing along with the issue on this forum. I suspect the issue is limited to a small but substantial batch of iPhone 5’s. They reckon they’ve sold 5 million+ so it might not be that many when you sell that many phones.

    Resolution:

    Tried two system restores one from a backup and the next one setting the iPhone as a virgin/new phone. Issue still present. Resetting just your network connections will have no effect either.

    Phoned Apple Care first agent did not know about the issue, passed to supervisor who had only heard of one report of this but by the sound of it that seemed like another issue not connected to what I was reporting. They were not aware of it only being AES encryption as the issue. They only recommended dropping from WPA2 to WPA. Anyway I made an appointment with a Genius at my local Apple Store. (Milton Keynes, UK). They say they had not heard of the issue. I presented them with screenshots of the packet loss when using WPA/WPA2 with AES encryption and they were happy to exchange for a brand new phone as it was only 6 days old.

    New phone has no issues with any encryption.

    I have no idea if this issue is hardware or software. I have access to a IPhone 4 and IPhone 4s both running iOS6 neither of these suffer this problem. I would suggest getting your phone exchanged with apple sooner than later in case it does turn into a hardware issue.

    Hope this helps some people…….
     
  6. Geckotek, Oct 7, 2012
    Last edited: Oct 7, 2012

    Geckotek macrumors G3

    Geckotek

    Joined:
    Jul 22, 2008
    Location:
    NYC
    #7
    Thanks for the heads up! Was gonna try Scany, but $5.99?!?! Gonna see if Network Ping Lite will do the job first.

    I actually haven't noticed the issue, but perhaps I've been blaming the WiFi issue on the fact that I have a CrashPlan backup job constantly running....only 24.9 days left! :rolleyes:

    Edit: Running WPA2 w/ AES on my Belkin Play N600 HD w/ no packet loss. Guess I'm one of the lucky ones. Never had any dings/scratches either. Have a hard time getting the purple fringe on the camera. All around I must have lucked out. :D
     
  7. superfox247 macrumors newbie

    Joined:
    Oct 7, 2012
    #8
    I know it expensive! I use it for other things as well in my job. Not sure if the free ones will let you do a continuous ping though. Let me know if you find one free or cheap that does though.
     
  8. Geckotek macrumors G3

    Geckotek

    Joined:
    Jul 22, 2008
    Location:
    NYC
    #9
    I use it for work on occasion, but usually just go to my desk when I need a -t. Probably just keep using the one I got until it doesn't fit my needs one day. If I have to use it for work on a regular basis, $5.99 isn't bad. But for me it's a rare occasion I need it on my iPhone. Usually just when I'm sitting at someone else's desk.
     
  9. ed. macrumors member

    Joined:
    Jan 31, 2008
    #10
    it's definitely the software!

    Hi all,

    I have an iPhone 4S that worked perfectly on WiFi (on a b/g/n network with WPA2/AES encryption), after updating to iOS 6 I started to experience very slow connection when on wi fi. The system itself was perfect and responsive: the weird thing was that Safari seemed to work perfectly all the time, while all other apps that relied on external internet connection lagged (very) badly on wifi. For example the same page in tweetbot's internal browser would take three or four times longer to load than on mobile safari. Images were downloaded line by line (56k modem-like experience!), and some apps (like instagram) would not load images at all.
    With the release of Letterpress the problem was blatant: my first gen iPad with iOS 5 on the same network had fast, reliable Game Center connection, while my iOS 6 iPhone 4S was slow and unreliable.

    I did everything: reset network settings, full restore… nothing seemed to work, until I stumbled into this thread!
    I gave it a go and configured my network to WPA with TKIP and magically things are back to their natural order!

    So I don't know if Superfox247 got a replacement phone with a different build of iOS 6 that solves the AES connectivity, but it looks to me that the problem is somewhere in the iOS 6 update…

    Anyway thank you for the post, it was driving me crazy!

    TL;DR: CHANGE SECURITY TO TKIP IN YOUR ROUTER!
     
  10. upnorth85 macrumors 6502

    Joined:
    Oct 2, 2011
    Location:
    MN, USA
    #11
    @superfox247 -one of the best post on the forum. This will help a lot of people and if this information gets to the right designer at Apple will remove the frustrating complaint of new iPhone5 owners worldwide. I have seen on other forums about this problem and your root cause analysis is brilliant.
     

Share This Page