iPhone 5 Email client fails when connecting to server with certs signed by personal C

Discussion in 'iPhone Tips, Help and Troubleshooting' started by blwegrzyn, Jan 16, 2013.

  1. blwegrzyn macrumors newbie

    Joined:
    Jul 14, 2011
    #1
    My mail resides on my own server with its own private CA that was used to sign the email server cert.

    I used sendmail and CA and certs were created with below commands:

    CA -newca

    openssl req -newkey rsa:1024 -nodes -keyout sendmail_req.pem -out sendmail_req.pem

    openssl ca -out sendmail_cert.pem -infiles sendmail_req.pem


    Before I switched to iphone 5 I had Iphone 3s and all worked fine.

    I would get a notification: cannot verify server identity, but after clicking continue all would work fine.

    The client would connect on port 993 to receive email and on port 587 to send.


    Now on iphone 5 I get error: Cannot verify Server Identity with no prompt to accept the cert.

    Is there any work around for it?

    I tried to export the cert from I mac and import to iphone but still no luck.

    It looks like since iphone 4 the certs not issued by legal CA's don't work?


    thx
     
  2. blwegrzyn thread starter macrumors newbie

    Joined:
    Jul 14, 2011
    #2
    I fixed that by getting certs from:
    https://www.startssl.com/?app=1

    they are free and work fine.

    Since Iphone 4 apple does not accept unknown CA Authorities.
     

Share This Page