iPhone iPhone 5 Jailbreak Peculiar Problem

Discussion in 'Jailbreaks and iOS Hacks' started by FixItNow, Jun 27, 2013.

  1. FixItNow, Jun 27, 2013
    Last edited: Jun 27, 2013

    FixItNow macrumors newbie

    Joined:
    May 3, 2013
    #1
    I'm on iPhone 5 iOS 6.1- evasi0n jailbreak.

    My iPhone is having issues. I was in an app emulator PPSSPP attempting to download the Atrac3+ plugin. Phone rebooted- or respringed. After that, most Cydia apps didn't work. The phone outputted no sound, whether from speaker, in calls, out. People could not even hear me on the other ends of calls. No ringer sound, although vibration worked and works. Video did not play, even in the photos app. I did see a video play in the Cydia ads when looking for a package with no sound to it. All the tweaks disappeared in settings app. I saw in iFile that many files in ~/mobile/Documents that I had where missing. My iPhone was close to full. Some games crashed on opening. Wifi works fine. Cydia is there and works fine. When I re-installed the tweaks & dependencies via Cydia, they worked fine. For certain tweaks to work correctly, and not malfunction, I had to make sure the dependencies where installed, such as PreferenceLoader.

    The problem that is still here now is that there is no sound, no videoplayback from any app- I think which uses iPhone video player. No sound in call from ear piece or speakerphone. A person does not hear on other end of my call.

    An intriguing thing:
    Airplay icon is there (I am not connected to anything, nor wifi), and it has no options for it. See Attached photos. This is where I think the problem could be and could be close to resolved, though I am not sure.

    Ruled out hardware issues, considering when this happened.
    I can access root from iFile just fine. I am not able to access root from iFunBox. I can only reach /var/mobile/Media/, though it says it jailbroken or "(Jailed)"- where it shows the name of the phone.
    I am able to open Cydia, install apps from Cydia.
    I can respring and reboot.

    I have made this detailed, so we can save time and make it easier for you all to help.

    Things I have tried:

    Using the evasi0n tool. Gives error "error hmm... restore failed (-1)."
    Tried on different computers.
    Restore from an iTunes backup I previously had no problems with- before errors. This is to see if it may repair a messed up setting. iTunes returns error: "Could not restore the iPhone because an error occurred."
    Also tried on different computers.
    iLEX RAT- I successfully cleared all cydia apps with option 12, still no video, sound, etc.
    Deleting "com.apple.iapd.plist" and reboot. Also tried deleting the other files similar to iapd, associated with accessories.
    Tried plugging headphones in and out a couple of times- no change or recognition, as if I didn't plug it in at all. No "headphones" in volume display when plugged in.
    Safe Mode- still no video, sound etc.
    Deleting all Cydia Tweaks & Apps -via iLEX RAT
    Alot of things from iphonenosound.com
    Reboot and Hold Up to turn off all mobile substrate apps. - still no video, sound, etc. ​

    In these attempts, the issues remained.

    Even if I said forget the jailbreak, It's possible a restore will not even work, considering, I've seen people restore and still have sound problems. I'd like to isolate the problem, rather than me get to iOS 6.1.4 or iOS 7 beta and find I have the same issue. I would have wasted time and a jailbreak. That I think it may not work, and of course do not want to lose my jailbreak. The phone is fine generally, I just like to find a way to at least restore all sound and video until next jailbreak.

    Many Tweaks I had installed:

    %hooks%law
    Auxo
    Velox
    DeepEnd
    Accentify
    Activator
    Barrel
    CallBar
    SbRotator 6- springboard portion disabled- since I saw issues with it.
    Color Keyboard
    Folder Enhancer
    Iconoclasm
    Springtomize 2
    Zephyr
    FullScroll
    iLEX RAT
    Mobile Terminal
    Scrollingboard
    Winterboard
    MyTunes
    BytaFont
    Giffy
    Crashreporter

    A few more small tweaks.
    The phone still ran fluently- no lag though safe mode would appear, now and again.

    Details in things that currently occur:

    Voice Memos says when trying record, "No Microphone Available Connect a microphone to record voice memos."
    No Music plays from music app, Videos do not play.
    No Sound in call.
    Speaker phone will not turn on. I press it, it shows its selected, then immediately unselects it.
    There is no output from the sound whatsoever. Even in the ringtones app.
    Of course, I checked the vibrate switch. Which is fine and set to off.
    All videos, whether in photos app, YouTube app, YouTube from browser gives an error. Error from photos app "This operation could not be completed." Error on some YouTube videos "Playback error."
    The phone recognizes no difference when headphones are plugged in.
    Bluetooth does not turn on at all. It just shows the spinning wheel when attempting to toggle on and is seen on the "Off" position later.
    Airplay icon is there. Shows as if I have something connected to it. I have never used it, accept and has no devices listed:

    I would appreciate help to get this resolved.

    Thank you.
     

    Attached Files:

  2. lukejc1 macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #2
    I've had a similar issue with my iPhone 5 where I get no sound from any app or notification. My phone says it's connected to something via airplay even though it wasn't. I read that it might have something to do with a cheap lightning cable/plug but I can't say for sure.

    To fix the issue I do a hard reboot by holding down the power and home button until the phone turns off and the Apple logo reappears. Then everything works as normal again.

    EDIT: If that doesn't work, a google search for "iphone no sound dock connector" may or may not give you some useful information.
     
  3. FixItNow thread starter macrumors newbie

    Joined:
    May 3, 2013
    #3
    Thanks lukejc1,

    I tried doing a hard reset, and reset it many times in the process of troubleshooting it.

    I did the google search. I had previously searched for this, funny.

    I was thinking that if it was a usual issue with a dock, it might show up as
    this photo suggests:

    bChl7.png

    This photo is from: http://forums.macrumors.com/showthread.php?t=1372660

    Mine shows all the controls:

    IMG_0011.PNG

    Anyway, I digress:

    I was thinking if it had to do with a dock, I would have been using wifi, airplay or a dock of some sort. Music does not even play, with the time showing, when a song is selected, it goes to the song and immediately cuts off- no playback time. Videos do not play. Not playing with no sound, they don't play at all. The issues occurred right after what could have been a tweak crash. My phone rebooted- or did a respring- not connected to anything, I think, and then these problems occurred.

    I ruled out just a usual sound issue because, microphone does not work (see my first post), and there is no video playback and no sound output or input- whatsoever...

    Thanks
     
  4. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #4
    Have you tried to install icleaner pro and disable the accessories plist? Might be worth a shot.
     
  5. FixItNow, Jun 28, 2013
    Last edited: Jun 28, 2013

    FixItNow thread starter macrumors newbie

    Joined:
    May 3, 2013
    #5
    That is so funny you said that. I not only tried that, but did it manually as well, well through the iapd files under /System/Library/LaunchDaemons...
     
  6. FixItNow thread starter macrumors newbie

    Joined:
    May 3, 2013
    #6
    Anybody else have any ideas? Will syslog or crash reporter help?
     
  7. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #7
    Fully return as new using a fresh copy of iOS 6.1.4 and make sure your phone is in DFU mode.
     
  8. FixItNow thread starter macrumors newbie

    Joined:
    May 3, 2013

Share This Page