iPhone iPhone 5/Jailbroken (Apps quit opening)

Discussion in 'Jailbreaks and iOS Hacks' started by Insane225, Jun 15, 2014.

  1. Insane225 macrumors newbie

    Joined:
    Jun 15, 2014
    #1
    My iPhone 5 has been jailbroken for some time now. It it on IOS 7.0.6. Once, in the past, one day a couple of my apps would go to open, and then crash before fully opening. I tried removing some of my jailbroken packages, and after removing a few, and restarting my phone, I could then open my MAIL and other apps (using MAIL as an example because it is my most important one that crashes). After fixing the problem, I could then re-install all the same Cydia packages I had just uninstalled and my MAIL would still open and work fine.
    Here I am, 2 weeks later, and have run into the same problem again. I have uninstalled all of my Cydia packages and restarted my phone, still not having luck with getting my MAIL app to open. The only Cydia packages I have left right now are:
    -Big Boss Icon Set
    -Cydia Installer
    -Cydia Substrate
    -Cydia Translations
    -evasi0n 7.x Untether
    -Repo Icons
    -Substrate Safe Mode
    -xSellize Security

    I'm not sure what else I can do. Not sure if I can remove anything else. I tried reinstalling all of these at the same time, but no luck.

    If there is a way I can restore back to the same version, I can do that and re-jailbreak but I don't think there is a way for me to restore the version I'm on right now (7.0.6 on an iPhone 5). But can you help me figure out how to either restore my phone to the same version so I can re-jailbreak, or to keep my MAIL app (and others) from crashing? thanks.
     
  2. Insane225 thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #2
    Sorry, I fixed my own problem.
    In case anybody else runs into this problem, I found a YouTube video that explained it all.

    Fix #1: Uninstall AppSync (didn't work for me)
    Fix #2: Uninstall afc2add (didn't apply to me)
    Fix #3: Uninstall possible other tweaks it may be (did that to an extreme)
    Fix #4: Settings < General < Reset < Reset All Settings (didn't work)
    Fix #5: Follow these steps:
    -Download/Open Cydia's App: iFile
    -When it opens, keep pressing "back" button until you get to the main page (because it doesn't open on the main page).
    -Then go to: var < mobile < Library < caches
    -Find "com.apple.mobile.installation.plist" and swipe to the right, and click "DELETE"
    -Then scroll until you find "com.apple.LaunchServies-054.csstore" and "Delete" that as well.
    -After doing so, restart your device and your apps will work perfectly!

    :) Thanks self! It took a lot of research.
     
  3. 1984world macrumors 6502

    1984world

    Joined:
    Aug 26, 2008
    #4
    Nicely written explanation. Thanks for posting such a well written piece of information. :)
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    Appsync and sketchy repos will do this just about every time.
     
  5. King Bowser macrumors regular

    Joined:
    Aug 2, 2010
    #6
    This happened to me except it only happens with Iheartradio and on facebook when I get messages.. which is really weird.


    I tried doing your last step and it didn't work.. I really don't want to lose my jailbreak :(
     
  6. King Bowser macrumors regular

    Joined:
    Aug 2, 2010
    #7
    Anyone ? If I can't figure it out by tonight I need to restore and see if that fixes if. I even tried ilex rat and no avail. :(
     
  7. Danimal1313 macrumors member

    Joined:
    Jan 12, 2013
    #8
    And it works too! I used to have issues with Safari crashing the first couple times I tried to open it. Now it works as it should! Thanks for the helpful post!
     

Share This Page