iPhone 5 LTE not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Nytro, Mar 15, 2014.

  1. Nytro macrumors newbie

    Oct 23, 2010
    Ok, it's like this: I have an iPhone 5 since August of last year. I never updated to iOS 7 until now because I was kind of afraid, due to many reasons (reviews I read, battery life, UI, easy-use issues, etc.), but I did it, because, you know, I couldn't use iOS 6 forever and, mainly, I wanted do enable LTE (actually, it's 4G, since I'm from Portugal and there's only 4G here, and don't worry, I know it's different, but I'm only being name-wise, but moving on). I updated last week, and I was kinda satisfied with everything, and I got 4G. However, like 2 or 3 days later, it just stopped working. All I got now is the 3G logo. I try to enable 4G in Settings and even tried data roaming and everything, but 'nada'! I tried to contact my carrier (TMN, aka MEO) and tech support and they told me it could be 5 things: there was no 4G coverage in my area (impossible, 'cause my friend in town has an iPhn 5c and he gets 4G, full signal), the phone didn't support the frequency used for 4G networks here (impossible, again, since I have already connected to 4G), the phone may have an antenna problem, SIM could be damaged or there could be some kind of error in the update to iOS 7 and to try to reset everything. I have warranty. Also, the phone's jailbroken. Can it have anything to do with it?
    Someone help me out here? I'm going crazy! :(
  2. Chris7811 macrumors newbie

    Dec 30, 2012
    hey it is the phone because

    there are people where I live in the us and verizon doesn't technically have LTE their LTE is 4G still because I have tested it with my iPhone 5 and my friends (mine AT&T, his Verizon) there is a huge difference that we both can see as well if you do not keep it updated at least try to but if not make sure you can and then keep it until there is a jailbreak out so it doesn't do that again.
  3. Darwin macrumors 65816


    Jun 2, 2003
    round the corner
    It is odd that you had a 4G signal when you first started. Your carrier (according to a quick Google search) is only using the 800/2600 bands for 4G.

    An iPhone 5 (GSM Model) can only use the 1800Mhz for LTE, the newer iPhones have all three for Europe models thus why your friend is getting service (same carrier?)

    There are 2 networks ie: Vodafone and Optimus which use the 1800 band. Was this what you were connecting to?
  4. Nytro thread starter macrumors newbie

    Oct 23, 2010
    I'm signed to a package provided by the carrier in which I have 15 GB of internet, which I can use with a 4G connection. I don't know about iPhone 5, but my friend's is a 5c and he gets 4G with no problem. From what I know, since I've called customer service, iPhone 5 should get 4G service, and when I called tech support, they told me the 1800mhz band would work with my phone. Either they're wrong or they didn't understand, or there's really a problem. I'm pretty sure I saw the 4G logo up there in the status bar at least once, but I turned it off, to save battery, and when I tried connecting to it later, only 3G would appear.

    Nope, I was connected to 'tmn', that's the name (recently changed to 'MEO', but the carrier name in the status bar and settings is still tmn, and that's for everyone until they change it)

    I guess I could take the phone and original packaging and bill and everything to a near 'tmn' store and explain to them what's up. I could be wrong, but if my iPhone doesn't connect to 4G at all, maybe I can get a replacement, with warranty (gotta uninstall jailbreak, though).
  5. The Doctor11 macrumors 603

    The Doctor11

    Dec 15, 2013
    New York
    Try and hold the home and sleep button at the same time until you see the apple logo. Hope that helps.
  6. Nytro thread starter macrumors newbie

    Oct 23, 2010
    Any of those 'conventional' solutions don't work, since I've tried them all and it's the most obvious thing to do (try resets/reboots, etc.). I need a more complex solution.

Share This Page