iPhone 5 missing 'forget this network' wifi option

Discussion in 'iPhone' started by thadoggfather, Sep 21, 2012.

  1. thadoggfather Suspended


    Oct 1, 2007
    whenever my iPhone goes into standby mode, I have to connect to wifi again.

    Every time it makes me enter a password.

    There is no option to 'forget this network' under connected wifi settings.

    I did a 'network resettings' and hard reset, going to try restoring then seeing.

    Setting up iPhone as new, not restoring from a backup.

    Anyone else? This is weird. My dad's 5 doesnt exhibit the same things AND I restored from an iOS 5 iCloud backup as well.

    Going to try a restore.
  2. Sone3D macrumors member


    Oct 1, 2011
  3. nicroma macrumors 6502a


    Jun 20, 2009
    Midwest, USA
    I set mine up as a new iPhone and the option is there for me.
  4. thadoggfather thread starter Suspended


    Oct 1, 2007
    hard reset didnt do anything either. going to try a reset.

    unless by hard reset you mean reset all settings and content.
  5. skiwil macrumors member

    Jul 2, 2010
    I have the exact same issue. If my phone is asleep for aim or two it completely forgets my network and I have to enter the password all over again.
  6. janderson0719 macrumors 6502


    Aug 25, 2011
    I actually started a thread earlier because I was having the same problem. What I did:

    1. turned off wifi
    2. turned on wifi
    3. select "other"… not your own network
    4. manually enter your network name
    5. select password type and then enter password

    It worked for me. Apparently, by doing this, it remembers the authentication key. Hope this helps you or anyone else.
  7. thadoggfather thread starter Suspended


    Oct 1, 2007

    it does it with my netgear, but not with my modem that has the wifi built in (i normally leave it disabled because netgear has traditionally been better)

    but on an ios 5 iphone 4 it doesnt always connect, but when i click it, doesnt ask for password.

    and my dads connects all the time on his 5 (the one that was restored from icloud backup)
  8. janderson0719 macrumors 6502


    Aug 25, 2011
    I had the same problem when I bought my new iPad, but a simple reset fixed that problem. The iPhone 5 was harder to get it to stay connected on wifi.
  9. thadoggfather, Sep 21, 2012
    Last edited: Sep 21, 2012

    thadoggfather thread starter Suspended


    Oct 1, 2007
    will give it a try.

    does this lead you to believe its a software-router compatibility issue of some type or hardware?

    When I try to restore, it says device not eligible for requested build :(
  10. eBoy90, Sep 21, 2012
    Last edited: Sep 21, 2012

    eBoy90 macrumors newbie

    Sep 14, 2012
    Having the same problem with the same setup. Noticed a few other people saying the same thing. Very frustrating.

    It won't let me connect using the 'other' option either. Don't know what to do
  11. skiwil macrumors member

    Jul 2, 2010
    Thank u for the other network trick. It seems to have worked, I'll have to do some more testing to make sure
  12. thadoggfather thread starter Suspended


    Oct 1, 2007
    I was able to connect using the other option..

    seems to have remembered it this go round! Thanks!! this was driving me nuts.

    (when I put the phone down for a few minutes and turn on the screen again, its connected to wifi instead of just stuck at '4g' until I enter password again.

    I think this might be a software bug related to specific routers too. If it were hardware, not this many people would be chiming in already on this thread and it would have faded into oblivion immediately.

    This seemed to crop up before iPhone 5 came out (with regards to an "iOS 6 wifi issue").

    And I wonder if I couldn't restore the device because that firmware is too new (the one for iOS 6 specific to iPhone 5) to be signing it again?) I dunno.

    thank goodness I could get it out of DFU mode by holding down both buttons again until I got the apple logo.

    I think the 'other' thing really ironed it out. And the issue didn't seem to be happening with my other cable modem/router combo oddly enough.

    My dad's didnt do it either, so in this case, "restore from backup" was preferable to setting up new haha.
  13. laser21 macrumors newbie

    Nov 19, 2012
    Im experiencing the same. Iphone 5 6.0,1, I will go to the store tomorrow and ask.

    thanks, the workaround works, but is annoying
  14. bandityo macrumors member

    Nov 11, 2012
    Mine did the same...what Janderson said is the way to fix it...mines worked perfectly since doing that a couple of weeks ago
  15. thadoggfather thread starter Suspended


    Oct 1, 2007
    I doubt given that it's happening on all these devices that anything can be done except hoping 6.1 addresses it.

    I haven't posted in here in a long time because I haven't seen it on **any** of my iPhone 5's since when I created this thread and originally had the issue.

    Of course, I don't use a ton of wifi spots just a few, and starbucks. Actually, I think I turn starbucks wifi off because LTE is muchhhh faster even if its my data, I have the faux unlimited.

    Maybe depends on router. But also been connecting to WPA protected networks where that's supposed to have the most issue I think.
  16. Tote vet macrumors newbie

    Nov 23, 2012
    This workaround solved my troubles too. It was experienced on iOS 5.1 & 6.0.1 by me.
    Thank you, saves a lot of time :) :apple:
  17. scottha macrumors newbie

    Dec 18, 2012
    I have tried EVERYTHING (reset network, wifi, location services, swing a black cat on a full moon), and this finally fixed it. Thank you, JAnderson!

  18. mey2 macrumors newbie

    Sep 7, 2013
    Worked for Me

    See janderson reply - this also worked for me - Thanks.

Share This Page