iPhone 5 MMS not working?

Discussion in 'iPhone' started by GadgetGeek407, Sep 23, 2012.

  1. GadgetGeek407 macrumors 6502a

    Mar 26, 2009
    Anyone else notice that MMS on iphone 5 is not working when sending to non apple devices? in this case it was particularly while on wifi and im guessing it may be related to the wifi issue
  2. superspud macrumors regular

    Dec 6, 2007
    I've had issues with this. Tried sending several pictures to my gf who has a non iPhone and she never received them. This was on LTE with no wifi.

    I never got anything saying the message wasn't sent. She just never received them.

    Not sure what to do
  3. imazu macrumors regular

    Jul 4, 2012
    just asked my friend to try sending one to me, she's using android and can't send it. i tried sending her one and she got my mms.
  4. TyKandi macrumors newbie

    Sep 23, 2012
    This maybe network based and not iPhone based. Contact your provider.
  5. imazu macrumors regular

    Jul 4, 2012
    ^my friend is on tm i am using verizon. i guess tykandi is right. btw, sent it not connected to wifi just cellular.
  6. mytran80 macrumors regular

    Mar 30, 2009
    Similar issue for me , can't send mms on my AT&T prepaid account with the iPhone 5
  7. Big Ern macrumors newbie

    Sep 27, 2012
  8. Iseador macrumors newbie

    Mar 31, 2013
    There is a far easier solution. I found (as have many others) that the problem is caused by profiles that get installed on your phone. To check to see if there are any go to settings > general, then go all the way to the bottom of the page just before reset and see if any "profiles" are installed. If so, remove and then try. Worked for both me and my girlfriend. Hope this helps!
  9. annaharris macrumors member

    Aug 21, 2012
    San Francisco
    I have faced same issue when i was trying to send mms message to another number. Only i can send mms messages to myself via imessages.*
  10. iPaddude macrumors newbie


    This is still a problem for every iPhone user I know. There was a work around where if u turned iMessage off it let you send but that no longer works!

Share This Page