iPhone 5 "no SIM" error

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Joybulb, Apr 2, 2014.

  1. Joybulb macrumors regular

    Joybulb

    Joined:
    Sep 3, 2011
    #1
    I've been using the phone on sprint for a year, and now I'm getting this error every one or two days. Where the phone says there's no sim installed or up where it usually says sprint it says "no sim". If I restart the phone it fixes it. anyone else have this or know what's up?
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #2
    happened to me on my first iPhone 4 on at&t. apple or sprint will try to replace the sim card first, or the sim try. however I've never seen this fix the issue in person or if you search google and read tons of others with the same issue over the years. my guess is that the actual sim card reader is shoddy in the phone itself.

    i would suggest starting by cleaning the sim card contacts first with a q-tip and some alcohol. if that doesn't work, try a new sim card from sprint. if that doesn't work (didn't for me), take it to apple, as you may need a replacement device.
     
  3. barkomatic macrumors 68040

    Joined:
    Aug 8, 2008
    Location:
    Manhattan
    #3
    I had this problem a couple times on AT&T and I would also fix it by turning the iPhone off and on. Eventually, I just opened the sim tray, removed the sim and just put it back in. That was three months ago and I haven't had the issue since.
     

Share This Page