iPhone 5 or earlier iPhone 5 Stuck in Headphone Mode

Discussion in 'iPhone' started by antiv6, Nov 14, 2012.

  1. antiv6 macrumors newbie

    Nov 14, 2012
    As the title says my iphone 5 is stuck in headphone mode, there are no headphones in it but the phone thinks that there is. Any ideas? I've tried plugging in headphones and taking them out and it did nothing as well as turning the phone on and off. It just randomly happened today, I haven't had headphones in for over a week and it wasn't like this earlier.
  2. mohsy90 macrumors 65816


    Feb 4, 2011
    New York
    Try a phone reset, if that doesn't work then it looks like you'll need to take a trip to the Apple Store.
  3. Vundu macrumors 65816


    Jun 10, 2009
    Manchester, UK
    Can happen if the phone gets wet.

    Is this a possibility?
  4. tardman91 macrumors 65816


    Oct 21, 2009
    Tampa Area, FL
    Have you tried plugging the headphones in, actually listening to music, pausing it, and then removing the headphones? That's how I've always been able to solve the problem on my iPhones past and present.
  5. antiv6 thread starter macrumors newbie

    Nov 14, 2012
    i did the reset, i messed with different headphones. I finally found a youtube video of a person who cut a q-tip then used the stick part and moved it around in there and somehow that worked. Idk how this happened it definitely didnt get wet
  6. Small White Car macrumors G4

    Small White Car

    Aug 29, 2006
    Washington DC
    How many times? When this happened to me it fixed itself after I did that about 30 times in a row.
  7. mattroman246 macrumors 6502


    Mar 19, 2009
    Upstate NY
  8. antiv6 thread starter macrumors newbie

    Nov 14, 2012
    what is the LDI? Everything works perfect now after the q-tip trick, it hasnt been exposed to water at all and its always in a case in my pocket. I used headphones today too and its working like it should when i took them out
  9. ndpitch macrumors 6502

    Jun 9, 2010
    I think LDI = Liquid Damage Indicator

    They are the little white dots on the phone (in the headphone jack, in the charger port, etc) that will turn a different color when wet.
  10. antiv6 thread starter macrumors newbie

    Nov 14, 2012
    oh, i thought the 5 only has one of those on the inside?
  11. PMEDLEY macrumors newbie

    Jan 10, 2013
    I had this same problem about a year ago. I searched the Internet for help. Almost everything I read suggested this had something to do with the headphone jack being dirty, wet or something lodged in it. I found it hard to believe that jamming the headphones in and out several times would fix this. I had the same feelings that blowing, freezing or vacuuming the headphone jack would fix my iPhone. I wanted to post this because, my phone did the same thing this evening. I got so frustrated because I couldn't remember what I did to correct it the last time. So, after about an hour of pulling my hair and going through every setting on my phone 20 times or so, I finally figured it out. I hope this helps anyone else going through the same issue. Go to your settings/ general/ accessibility/incoming calls. Change your incoming calls to default or speaker. Go back to your home screen press the volume and you most likely will see volume (headphones). Go back to your settings/ general/ accessibility/ incoming calls. Change your incoming calls to headset and this will fix your phone.
  12. Charlenemarie macrumors newbie

    Jan 21, 2013
    My phone to is stuck on headphone setting. I've tried plugging in and out the headphones and changing setting. Nothing has worked
  13. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    Ever spilled anything on it?

    Did you try a DFU restore?
  14. Olebaxer macrumors newbie

    Apr 26, 2013
    It worked for me!!! Settings-General-Accessibility-incoming Calls. Switch to speaker.
    Tnx so mch
  15. H2ulgsyd macrumors newbie

    Apr 29, 2013
    This was literally so helpful!!! I made an account for the sole purpose of thanking you - you are a lifesaver. Everyone please read this, it worked for me. Thank you!
  16. lovemyiphone5 macrumors newbie

    Sep 12, 2013
    Settings/general/accessibility/incoming calls/ switch to speaker! It worked!!!!
  17. Arspeer macrumors newbie

    Oct 21, 2013
    The cut off q-tip worked for me. Only took two or three times. Was a bit dirty in there.
  18. thatoneguy82 macrumors 68000


    Jul 23, 2008
    Beach Cities, CA
    There's also one inside the SIM tray.
  19. emseven macrumors regular

    Sep 19, 2013
    When this happened to me it was lint in the cavity that the Genius blew out with compressed air.
  20. hirschhorn macrumors newbie

    Oct 28, 2013
    Problem solved

    Thank you so much, this worked for me too (after fruitless hours of blowing, sucking, probing my headphone jack).

    My default had been set to headphone after updating to ION 7.3. When I would listen to music, i could unplug the headphone jack and the music would keep playing. When the phone rang, if there were no headphones in it wouldn't ring. Just as described above.

    Per the solution quoted above, I changed the setting to speaker, then called the phone, that worked. I left it like that for about 30 minutes, and then I changed it back to default, and everything works correctly. Don't be discouraged if you change to speaker, then change back to default and headphone is still engaged. It took my phone about 30 minutes to clear up. But now it works, no problem. Thank you!
  21. cynics macrumors G4

    Jan 8, 2012
    I see you fixed it but I had this happen to me the other day after using a Square (credit card reader which might I add I can't get to work in iOS 7 properly).

    A reset (power + home buttons) fixed it. Very strange and kind of scary at the same time. You don't realize how important a phone can be until there is the potential of it not working properly.
  22. Thankyou! macrumors newbie

    Nov 4, 2014
    I struggled with this same problem, and resorted to rubbing alcohol, q-tips, and jamming a sheet of toilet paper down the headphone jack. Nothing worked!! I was worried that the alarm function would not work since it was stuck in headphone mode, and I had to get up early... After reviewing 3 different websites, I found your post and it worked!! Thank you so much for taking the time to post this, and having such clear instructions. I also created an account just to say thanks!! Your solution worked for me!!
  23. RIP123 macrumors newbie

    Nov 6, 2014
    Mines done it too.

    My iPod (5th gen) has not got wet at all because I always keep it in a case when I go out, and when I'm at home I never drink while using it because I've done it before on my DS and that broke. When I try and play music off the music app, it just skips past all the songs, and it doesn't play sound from games because it thinks it has headphones in it. Also, even when I tried to use head phones in it, it still doesn't work (I've tried multiple ones). I've tried wiggling them around and blowing into the it and I there is definitely nothing inside it. It's not in warranty either, so I can't take it back. :mad: :(
  24. ChristyCC macrumors newbie

    Nov 10, 2014

    Thanks so much for this solution. Worked for me! The button sequence I needed to use was named slightly differently. Took me a while to figure out so thought I'd share to save others a bit of time...I recently updated my iPhone 5 to iOS 8.1, so perhaps that's when things changed. Here's what I did:
    settings/general/accessibility/call audio routing (you need to scroll way down to the bottom to find this!) and then switch between speaker and headset as described above.

    Incidentally, i took my phone to an Apple store last week. Waited an hour for a Genius Bar appointment and was told it couldn't be fixed, but I could have a new handset for GBP200 (about USD250). Glad I had one more look on here before I went back to the store!!
  25. dawt.dash macrumors newbie

    Dec 23, 2014
    Yep, q-tip thingy worked well for me. Wiggled it around a bit, up and down, got a lot of dirt/dust out of there. Turned on some music and speaker was working again. THANK YOU!!

Share This Page