iPhone 5c problems

stephenxiii

macrumors regular
Original poster
May 12, 2009
156
0
Glasgow
I am a beta tester and using 10.1 public bata 4
and for the past week ,y phone has started to act weird

1. i cant play videos, they load up on youtube/netflix etc but wont play
even ones in my photo/video app

2. my ringtone/text and alarm alerts don't make there ringtone sound just vibrate

i have reset the phone to factory settings
used an air can to blow into the 3mm audio jack incase something was stuck in there causing the lack of ringtone

its rather important to have a phone as its mainly used for work

Any ideas would be great.
last action i would choose would be apple
 

itsray

macrumors 6502
Jun 5, 2016
474
316
what difference will that make and would i have to download latest firmware then
because doing that you're wiping the phone and loading fresh software on it. which would be probably 10.0.x, and if you do it from iTunes then yes you'll have to download the latest firmware. or if you have a previous back up of something other than 10.1 beta try that
 

stephenxiii

macrumors regular
Original poster
May 12, 2009
156
0
Glasgow
the only back up i have is 10.1 beta
so i'm assuming that if i do a DFU and install 10.0 and then restore from backup it wont work or will it go back to beta
 

itsray

macrumors 6502
Jun 5, 2016
474
316
the only back up i have is 10.1 beta
so i'm assuming that if i do a DFU and install 10.0 and then restore from backup it wont work or will it go back to beta
if you did that then the dfu restore would of done nothing/be a waste of time and you'll be back to where you are now.