iPhone 5s App update bug??!? (no animation when manually updating)

Discussion in 'iOS 7' started by Colonel Badger, Sep 24, 2013.

  1. Colonel Badger macrumors 6502

    Jun 30, 2008
    So I just updated from a 4S to an iPhone 5s. I have auto-updates on, but like others have noticed that sometimes there are still apps pending update (i'm also seeing apps automatically update, so in part the auto-updates seem to be working).

    What i'm finding strange is, if I tap on a pending update, the app starts to update in the App Store with the percentage complete working its way around the circle. However if I return to the Springboard the app in question thats updating DOES NOT show any form of animation. It shows no sign that it's updating. I could have sworn that on my 4s when I did the same that I would see a "pie chart" like animation over the top of the app icon, much like when you install an app for the first time.

    Anybody else seeing this? Is this a bug, or perhaps this is the correct behavior when auto-updating e.g. Not to show apps that are updating in the Springboard, only in the app store?
  2. navodwickra macrumors 6502


    Aug 24, 2013
    Leeds, UK
    Auto update never worked 100% since the 1st beta. I find it not that reliable.
  3. Colonel Badger thread starter macrumors 6502

    Jun 30, 2008
    Well, after finding an app "stuck" updating. I rebooted the phone. Now I see the animation on top of the app icon on the Springboard. So clearly it IS an iOS 7 bug. No idea if this is an iPhone 5s bug or a more general iOS 7 bug, but rebooting fixed it.

    The reboot also fixed the availability of iWork apps (before the reboot they still cost money, now they're free).

Share This Page