iPhone 5s hates my router

Discussion in 'iPhone' started by DougTheImpaler, Feb 26, 2015.

  1. DougTheImpaler macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #1
    My iPhone 5s absolutely despises my router and I'm not sure what to do. I have a Linksys EA4500. Other wifi clients include an iPad Mini 2 with LTE, a Galaxy S5, a Motorola Droid Maxx, a Windows desktop using a Broadcom PCIe adapter, a 3rd gen Apple TV, and my Mac Pro running Yosemite. A pretty good mix of Google, Microsoft, and Apple devices. They're all running the latest available (so Lollipop on the S5, KitKat on the Droid, iOS 8.1.3 on the Apple, and Windows 8.1 on the PC).

    Of all these devices, the only one with wifi issues is my iPhone. It manifests itself as being OK for some stuff like browsing the web or social media apps, but long transfers take forever. Updating Evernote and Facebook today took about a half hour, for example. The same apps updating on my iPad took about 2 minutes.

    Things I've tried (from least destructive to most):

    Forget/rejoin network
    Wipe network settings on phone
    Completely reset phone and set up as new
    Had Verizon begrudgingly replace it - this took some effort but they eventually did

    The new one has the same problem as the old one, and it's been going on since around the 8.1 update. Is *anybody* experiencing wifi issues with an iPhone 5s still? I'd blame the router/iOS combination except that the iPad is fine. I don't know what else to do and I'm just very frustrated. I don't think this is something I should have to replace the router for, but I guess that's next.
     
  2. XTheLancerX macrumors 68000

    XTheLancerX

    Joined:
    Aug 20, 2014
    Location:
    NY, USA
    #2
    Turn the router off and then back on? I know it sounds stupid, but just try it. Anyway, for some reason on only mobile devices in my house, the WiFi starts going in and out. Laptops/anything else work fine, but just tablets and smartphones wig out. Sorta weird. Anyway, you can do all you want to the devices and it does nothing, but resetting the router real quick fixes the issue.
     
  3. DougTheImpaler thread starter macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #3
    That is one thing I hadn't tried. It didn't seem to make a dfiference.

    A slight difference has been made by switching from teh 5GHz network to the 2.4GHz one. Now it downloads consistently, though it's only using about 1/6 of my internet connection to do it. Speedtest on the phone is a smooth 8mbit instead of the 50mbit plus I get on my Mac and my iPad. It doesn't take an eternity to update apps at least, so if this continues to hold I can live with it.

    Maybe it's some sort of incompatibility between the router and the wifi chip in the phone. The iPhone 5s uses a different wifi chip than the iPad does, and the iPhone 6 uses a third one. I also found last night that the iPhone works great on wifi that's not my home wifi. I guess what I really need to do is see if I can find someone else with the same router and see if it does that on their network.
     
  4. MH01 macrumors G4

    MH01

    Joined:
    Feb 11, 2008
    #4
    Have you updated the firmware on your router?
     
  5. DougTheImpaler thread starter macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #5
    Yeah, the router says no update available and the version installed matches what's on the Linksys support site.
     
  6. Woochifer, Feb 27, 2015
    Last edited: Feb 27, 2015

    Woochifer macrumors 6502a

    Joined:
    Apr 22, 2007
    #6
    You could also try reconfiguring your router and all of your devices to only operate in Wireless-N mode. In the past, I've had problems when newer wi-fi specs roll out, and I have to operate the router in mixed mode to support devices using different wi-fi modes. With two different routers, the issues went away after I configured or upgraded all of the devices to the same wi-fi mode, and set the router to only support one mode.

    The only issue would be if you have some older Wireless-G devices on your network. My PS3 and satellite receiver both used Wireless-G, so I bought a Wireless-N wi-fi bridge and plugged both devices in using the Ethernet ports. Your overall wi-fi reliability might work a lot better by no longer having to support older devices.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  8. KUguardgrl13 macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #8
    If I may ask, who is your Internet provider? My boyfriend and I have a regional cable provider called WOW! and have had problems with our iPhone 5's and iPad Mini 1st gens. The router is a Motorola one provided by the cable company. His roommate hasn't mentioned the same issues that we've noticed on his Galaxy Nexus or gaming PC. I've had some trouble with my rMBP, but that could also be Yosemite.

    We've tried resetting the router, but it doesn't seem to help Safari load faster or Netflix buffer less. I'm sure it doesn't help when his roommate is playing MMORPGs though. I suspect the ISP is not giving us the speeds we're supposed to, though it's weird thag the Apple devices are particularly effected.
     
  9. DougTheImpaler thread starter macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #9
    Our ISP is also a local/regional provider, called ITV-3. However, the router is one that I purchased myself, so I think maybe my issue is different.

    Solved my issue. Bought an Airport Express and disabled wireless on the Linksys. I can max out my internet connection with every device in the house, according to the Speedtest app. Must be something between the router and the wifi chip in the iPhone.
     

Share This Page