iPhone 5s keeps disconnecting when plugged into MBA 2015

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Orizence, Jul 4, 2017.

  1. Orizence macrumors 6502

    Joined:
    Nov 10, 2014
    #1
    So heres the thing sometimes when I plug my iPhone 5s into my MBA it constantly connects and disconnects about every second or two, now if I fiddle with the end plugged into the laptop and play with the Magsafe connecter it becomes fine all of the sudden. Im not too sure if its a problem with my laptop or the iPhone but it seems like some others have had this issue but I never saw a solution posted to those threads.

    Has anyone else had this issue? This only happens with my iPhone and my MBA, if I plug it in to my old G5 its fine.
     
  2. crawfish963 macrumors 6502

    crawfish963

    Joined:
    Apr 16, 2010
    Location:
    Texas
    #2
    Likely this is a cable failure. Have you tried a different cable?
     
  3. Orizence thread starter macrumors 6502

    Joined:
    Nov 10, 2014
    #3
    Its any cable I have tried with this iPhone and Laptop
     
  4. crawfish963 macrumors 6502

    crawfish963

    Joined:
    Apr 16, 2010
    Location:
    Texas
    #4
    I would guess, then, that your lightning connection port on your phone is failing or has failed. Your options would be to repair it yourself, or have it repaired.
     
  5. nieks macrumors 6502

    nieks

    Joined:
    Apr 7, 2016
    Location:
    The Netherlands
    #5
    Have you cleaned out your USB ports and lightning ports AND cleaned the connectors? Use an airduster to blow out all dust in the ports.
     

Share This Page