iPhone 5S losing airplay connection with apple tv

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Girasole, Dec 29, 2014.

  1. Girasole macrumors newbie

    Joined:
    Jul 18, 2011
    #1
    Hello everybody,

    I really have a problem here with my iPhone 5S (iOS 8.1.2).
    I can connect via airplay to my apple tv (3. Gen, latest firmware), but after 1 or 2 songs (or just in the middle) it loses the connection. This happens again and again.

    With my iPad mini and iPad and MacBook Pro it's working well. The problem really seems to be with my iPhone only. I have already installed the iOS from scratch. I also reset the network settings.

    I would appreciate if someone could help me or here. I really don't have a clue...

    Thanks and best regards,
    Girasole
     
  2. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #2
    I had a similar problem. I use an Apple Time Capsule for WiFi, and it uses both the 2.4ghz and 5ghz for WiFi. My Apple TV connects via the 5ghz network. When my iPhone is on the 2.4ghz network, I have problems with stuttering and disconnecting. When I force it to use the 5ghz network, it works great.
     
  3. Girasole thread starter macrumors newbie

    Joined:
    Jul 18, 2011
    #3
    Hi Aristokrat,

    Thanks for your reply!

    My WiFi router provides also both frequencies (2.4 and 5GHz).
    But:
    My iPhone 5S is in the 5GHz WiFi like also my iPad mini. My Apple Tv is connected via LAN cable. With my iPad mini I don't have airplay problems, but with my iPhone.

    Can it be really the root cause here?
     
  4. Girasole thread starter macrumors newbie

    Joined:
    Jul 18, 2011
    #4
    I have linked my iPhone into the 2.4GHz Wifi and the problem remains.

    Is anybody else having this issue?
     
  5. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #5
    Sorry that didn't work. Hopefully you find a solution soon!
     
  6. Girasole thread starter macrumors newbie

    Joined:
    Jul 18, 2011
    #6
    I think I got the solution here:
    I deactivated airplay on my Apple TV and then activated it back again.

    Up to now the airplay connection with my iPhone is stable.

    And I hope it stays! #
     
  7. firestorm888 macrumors newbie

    Joined:
    Jan 4, 2010
    #7
    Works *every time* for me

    Girasole - your fix works *every time* for me when my AirPlay goes out. So much more convenient that power cycling both my 27" iMac, iPhone, and AppleTV.

    Thanks again for the post!
    -Mark

     

Share This Page