iPhone 5S not syncing music properly, songs appear grey and "skip"

Discussion in 'iOS 7' started by Greene1123, Dec 26, 2013.

  1. Greene1123 macrumors member

    Joined:
    Mar 21, 2013
    #1
    So here's the long annoying story

    The other night I decided to add album artwork to a few albums that didn't have any and iTunes wouldn't recognize when I hit "get album artwork". So I added artwork manually to songs roughly A to C before realizing it was taking too long so I stopped. I plugged my iPhone in to sync.

    That night I went to play some music but when I tried to play one of the tracks I edited it skipped over it. I tried playing all the others and they didn't work either. I plugged in my iPhone to sync again. No fix. I restarted my iPhone and computer. No fix. I ran disc utility (just cuz it fixes the issue sometimes) but no fix.

    So I did a test (horrible decision) and decided to try syncing only "selected playlists, artists, albums, and genres" and de-selected all of the artists A - C. I synced it. And now allllll of the tracks with artists names A to C won't play on my iPhone. I've tried resetting everything multiple times with no success.

    Songs that wont play appear grey on my iPhone with a red square next to them. Help?
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #2
    are any of these songs purchased? maybe try hitting transfer purchases and see if that helps.
     
  3. capandjudy macrumors member

    capandjudy

    Joined:
    Oct 31, 2013
    Location:
    Huntington, WV
    #3
  4. Greene1123 thread starter macrumors member

    Joined:
    Mar 21, 2013
    #4
    I FIXED IT!

    on the iPhone: Settings > General > Usage - manually delete all the music on the iPhone.

    Then resync all the music. BOOM
     

Share This Page