iPhone 5S wont charge even though it says it is

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Danj1978, Jun 9, 2014.

  1. Danj1978 macrumors newbie

    Joined:
    Jun 9, 2014
    #1
    I have an iPhone 5S that has stopped charging. When you connect the lightening connector it says it's charging but the % wont move. Phone eventually goes flat. I have tried another battery with no luck. The phone connects to iTunes and I have updated it. Any suggestions would be greatly appreciated. Cheers Dan
     
  2. sammy-boy macrumors regular

    Joined:
    Nov 2, 2013
    Location:
    Staffordshire, UK
    #2
    Have you tried another charger in case yours is faulty, is it a genuine one?

    Also could be worth checking the lightning port on your phone to see if its got any dirt or crud in it. Your phone hasn't gotten damp recently has it?
     
  3. Danj1978 thread starter macrumors newbie

    Joined:
    Jun 9, 2014
    #3
    Thanks for the reply. I have tried a number of different chargers with no luck. Genuine and non Genuine. I have looked into the doc connector and given it a good clean but still didn't make a difference. Phone hasn't been near moisture or any sort of liquid. I tried the battery out of the phone in another 5S and it charges fine. I have ordered a new doc assembly so I hope to give that a try tomorrow. Cheers Dan
     
  4. angrybird2411 macrumors newbie

    Joined:
    Jun 12, 2014
    Location:
    quang ngai
    #4
    I think you should check charging equipment before use, should use genuine. If not, you should still bring a service center for repairs.
    Wish you success.
     

Share This Page