iPhone 6: cannot log into my Apple ID on iMessage. Password error.

Discussion in 'iOS 8' started by tirexstorm, Sep 19, 2014.

  1. tirexstorm macrumors regular

    Joined:
    Oct 22, 2007
    #1
    I have two apple IDs (which I wish that I could merge). A gmail email address that I use for the iTunes store and a me.com address that I use for icloud syncing. For some reason in the past I used my gmail account with iMessages.

    When I got my new phone today, I accidentally logged in to my me.com account for iMessage. Any time any of my friends responded to my old iMessages, I would get it on my ipad, but not my iphone 6. I logged out of my me.com login on iMessage on my iphone 6 and tried to log in to my gmail account. However everytime i try to change my Apple ID a dialog box pops up that says, "Enter the Apple ID password for xxx@gmail.com." I keep entering it correctly and then the dialog box reappears. After the 3rd attempt it will tell me that my password is incorrect. I am 100% dertain that I am using the correct password, and even logged out and back in to my iTunes account on my mac to verify. Any suggestions?
     
  2. KenAFSPC macrumors 6502a

    Joined:
    Sep 12, 2012
    #2
    I have the same issue. Oddly, the issue only affects my iPhone 6.

    I have no trouble logging into the same iMessage account on my iPad.
     
  3. tirexstorm thread starter macrumors regular

    Joined:
    Oct 22, 2007
    #3
    I ended going to the genius bar. Resetting the settings solved the issue.
     
  4. KenAFSPC macrumors 6502a

    Joined:
    Sep 12, 2012
    #4
    I just tried resetting my settings. Didn't work.:(
     
  5. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #5
    The last time that happened to my wife's phone I turned off iMessage for a few minutes, and when I turned it back on I was able to log in with the non-me address. Good luck!
     
  6. KenAFSPC macrumors 6502a

    Joined:
    Sep 12, 2012
    #6
    Thanks! Turning off iMessage for a few minutes fixed the problem.
     

Share This Page