iPhone 6(S)(+) iPhone 6 Display Issues

Discussion in 'iPhone' started by ryanapple, Mar 23, 2018.

  1. ryanapple macrumors newbie

    Joined:
    Sep 29, 2017
    Location:
    Singapore
    #1
    Hi all,

    Last Sept I did a 1-to-1 replacement iPhone 6 due to a swollen battery on the previous 6. Lately when I boot up the replacement phone(as it was a spare phone so I didn't use it often), the phone would boot up with a Apple Logo and the image will either slowly fade black or turn white completely.

    The phone does give off the charging and lock sound after it boots pass the Apple logo like a normal iPhone but will just show a blank image with the backlight on. If I were to leave the phone charged and in locked state for more than a minute, when I click the home button, the display will suddenly work and show the home screen and respond to my touches like a normal phone. Does anyone know if this is a display or iOS software related issue?

    Thanks in advance!
     
  2. Newtons Apple macrumors Core

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #2
    Sounds like a hardware problem to me.

    Even out of warranty, if you could have Apple take a look . . . you never know, they might replace it. I know everyone says that the replacement phones are all like new but many had a problem and had to be fixed but if Apple did not detect that problem . . . . .
     
  3. Juheon macrumors newbie

    Juheon

    Joined:
    Jul 29, 2018
    #3
    Hey, when did you got it replaced? Within 90 days since the swap, you get an extended warranty. Check that out if it happened recently.

    I use iphone 6 too, but I haven't observed that before.
     
  4. BugeyeSTI macrumors 68020

    BugeyeSTI

    Joined:
    Aug 19, 2017
    Location:
    Arizona
    #4
    Considering he stated that the phone was replaced September 2017 I’d say he is WAY past 90 days...
     
  5. ryanapple thread starter macrumors newbie

    Joined:
    Sep 29, 2017
    Location:
    Singapore
    #5
    Yup it was way past 90 days since the replacement. In the end I took it to my Apple Store and told the rep that I had experience the weird issues but didn't realize it early as it was a spare phone. I sent the phone in for inspection and they reseated the display cables and the issue is happening way lesser than before but might just freak out sometimes and show the static lines but after locking it and leaving for a while things will be back to normal.
     

Share This Page