iPhone 6 dropping cell data connection

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ellisin, Sep 24, 2014.

  1. ellisin macrumors newbie

    Joined:
    Jul 2, 2013
    #1
    I'm finding that my iPhone 6 loses its cellular data connection periodically.

    It can't use cellular data to connect to the internet and Siri won't work. Turning the phone off and on restores the connection. This wouldn't be a big deal, but when the connection drops no messages come through (when I restarted the phone today, 2 iMessages and a voicemail notification immediately arrived). I don't think I'd mind if there was any visual clue that the connection wasn't active; the screen is showing 3g or LTE on the top like normal. I thought this was due to being in a low coverage area (at home we get 1 to 2 dots on signal strength), but this just happened elsewhere where I had a strong signal. Anyone else having this problem? Is there a way to identify when the data connection has dropped so that I can restart the phone?

    This is a Verizon 64gb iPhone 6 running iOS 8 (I didn't do the update that was briefly available)
     
  2. thaghost macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Winter Garden, FL
    #2
    I'm having the same issue with my iPhone 6 plus on verizon. I tried resetting my network connections, but that didn't help. I can't figure out any rhyme or reason why it's happening.
     
  3. maliu macrumors 6502a

    Joined:
    Jun 24, 2010
    #3
    I turned on both voice and data in settings. It's improved it for me.
     
  4. LiveFreeDie macrumors regular

    Joined:
    Aug 19, 2010
    #4
    I too am also having a problem with my data speeds on my iPhone 6. I just switched to verizon from at&t and i'm constantly getting just 3G and when I should be getting LTE. And when I do get LTE the speeds are solo slow.

    I've done some research and others have said to call customer service and have them "reprovision" your account. I tired to ask them to do that today for me and instead they said it was their network coverage and issued me a ticket and said they would get bad to me in a few days.

    I'm gonna try back and call them tomorrow.
     
  5. odie625, Sep 26, 2014
    Last edited: Sep 26, 2014

    odie625 macrumors newbie

    Joined:
    Sep 26, 2014
    #5
    Got my phone on Sunday, had this problem all Sunday night, not realizing it because I was connected to wi-fi at home. Eventually started digging around and figured it out due to not being able to text a picture to an android user.

    Monday morning all was fine, connection was restored. I assumed there was provisioning that had to happen due to the phone being new, so I forgot about it. Yesterday my data connection was basically gone. I went to the Sprint store, they gave me a number to call. That guy told me to go home to my wi-fi, restore the phone. Blah blah blah. I must have restored this thing ten times now (awesome).

    Long story short, this morning I woke up with a connection, but then it went away again. Called the Sprint number from yesterday and got Bob. Bob spent time on the phone with me and read through various things on his end that may be causing this. Came across the issue you're having in this thread and he suggested I turn off my LTE.

    Turned it off and had internet instantly. Whatever he was reading explained that there are issues with connectivity when the phone is trying to switch between LTE & 3G. If it has a low LTE signal, then it acts like there is no internet at all. He suggested keeping the LTE off until they put out a fix for it.

    I am now a happy person but will probably blame every future problem on all those stupid resets I did.
     
  6. marcomartins macrumors newbie

    Joined:
    Nov 2, 2014
    #6
    I'm having exaclty the same problem and I could fix it like you said.

    The problem is that I have a friend with an exactly same iPhone6 and with the same carrier as mine and he don't have any of this issues. He can connect to 4g with no problem.

    I'm currently dowloading ios 8.1 to perform a factory restore by DFU to see if the problem is solved, if not tomorrow I'll take it to the warranty :(
     
  7. Matt0210 macrumors newbie

    Joined:
    Jan 15, 2015
    #7
    I also have a iPhone 6 64gb Verizion running on the latest IOS, and i am also having this problem.
     
  8. Yaboze macrumors 6502a

    Yaboze

    Joined:
    May 31, 2007
    Location:
    The Garden State
    #8
    I am also having this issue with a verizon iphone 6.

    It seems to lose all data connectivity. Even wifi doesn't work. I have to restart the phone for it come back. Voice (cellular) works ok. It seems to happen every 4-6 weeks.
     

Share This Page