iPhone 6 games/apps problem

Discussion in 'iPhone' started by dxy, Dec 23, 2014.

  1. dxy macrumors newbie

    Joined:
    Dec 23, 2014
    #1
    I recently realized, that my iPhone 6 64GB Silver has some kind of problem with high end games, I firstly noticed it when I started GTA: San Andreas for the first time (had it bought for iPad 4 before), while playing, I noticed some frame drops here and there, all the time. On my iPad it ran COMPLETELY smooth without any lag whatsoever - on iPhone 6 it should run even better. It is playable, but it is not smooth as my iPad 4 and not as smooth as on other iPhones 6 - i know from watching yt videos. It is the same with Asphalt 8 - it doesnt run as smooth as on other iPhones 6. I've been on iOS 8.1.2 since I got my iPhone (last week). Have cca 30 GB free space on phone. All smaller games run without any problems.

    Have you got any idea what may be causing this?
    I would be really thankful if someone could help me with this situation.
     
  2. benfica88 macrumors regular

    Joined:
    Nov 21, 2008
  3. RoboWarriorSr macrumors 6502a

    Joined:
    Feb 23, 2013
    #3
    Could be a possible defective device though getting Apple to replace it is another story. I had a 4s with similar problems but I couldn't get a replacement until I had a noticeable hardware defect on it (like dead pixel or something). On the other hand, Apple replaced my MacBook Pro's logic board after I displayed COD 4 lagging (a well known game that shouldn't lag on that particular model). I would recommend seeing if the Apple Store iPhone have GTA, or get a friend, and show the unresponsive gameplay. My 4s runs GTA quite well so I'm suspecting the device to be defective.
     
  4. Bahroo macrumors 68000

    Joined:
    Jul 21, 2012
    #4
    App isnt optimized for the iPhone 6 so..or very well could just have a defective i6 with a defective logic board
     
  5. XTheLancerX macrumors 68000

    XTheLancerX

    Joined:
    Aug 20, 2014
    Location:
    NY, USA
    #5
    May want to do a restore to try and isolate the problem first before you take it to an Apple Store, if you ask me.
     

Share This Page