iPhone 6+ lag when accessing photo library through messages

chrrie

macrumors newbie
Original poster
Sep 20, 2014
10
5
Have anyone noticed that it takes a while to launch your photo library when trying to text pictures?

Messages/Camera Icon/Photo Library/All Photos. Every single time I do this it takes 8 seconds for the photos to load. I've got a lot of pictures, but my 5 didn't have this issue.
 

myscrnnm

macrumors 65816
Sep 16, 2014
1,379
792
Seattle, WA
Out of all the lag that's happened to my 6 Plus, this is the one that hasn't happened most. Have you tried restarting your phone?
 

Angel841

macrumors member
Jul 29, 2010
30
0
Had the same problem, even the app crashed and won't load any pictures from the messages app. Just disabled the speak screen from the accessibility settings and it doesn't lag or crash anymore.
 

iggypod

macrumors 6502a
Jun 23, 2010
703
44
Had the same problem, even the app crashed and won't load any pictures from the messages app. Just disabled the speak screen from the accessibility settings and it doesn't lag or crash anymore.

Wow. Thank you so much - you just solved it for me on my 6+. It was driving me nuts. The photos now appear instantly again and I can attach them without messages crashing. Thank you!
 

Angel841

macrumors member
Jul 29, 2010
30
0
Wow. Thank you so much - you just solved it for me on my 6+. It was driving me nuts. The photos now appear instantly again and I can attach them without messages crashing. Thank you!
I even restored my phone as new twice before discovering this. Lets see if today's 8.1 fix it, I like the speak screen feature.
 

iggypod

macrumors 6502a
Jun 23, 2010
703
44
I even restored my phone as new twice before discovering this. Lets see if today's 8.1 fix it, I like the speak screen feature.
I was ready to restore if 8.1 didn't fix it today. Nice catch, I wasnt lookingn anywhere near accessibility features to fix it!