iPhone 6 Plus DOA?

Discussion in 'iPhone' started by SOLLERBOY, Oct 10, 2014.

  1. SOLLERBOY macrumors 6502a

    Joined:
    Aug 8, 2008
    Location:
    UK
    #1
    Hi, Ive been away for a few weeks and have just opened my 6 plus I got at launch. it wouldn't turn on so I plugged it in and after a few minutes I get the battery icon with a little bit of red in it.

    I just assumed it had ran down but it's now been that way for about 30 minutes, my iPod touch 1g does this sometimes but only takes a couple of minutes till its working again. Does anyone have any ideas?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    You may have a bad battery, give it a little more time, but if its not charging and staying in the red area then take it back to apple for an exchange.
     
  3. toddlouderback macrumors newbie

    Joined:
    Oct 7, 2015
    #3
    Don't feel bad got a new iphone 6s plus yesterday and I didn't even get the battery low light it was completely dead.
     
  4. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #4
    Something must be wrong as I have never got a new phone that did not have at least 50-80% power remaining in the battery when removed from the box. If yours was dead I am thinking there must be a hardware problem or maybe the phone was accidentally put in the box while turned on. I am thinking hardware/battery problem.
     
  5. magbarn macrumors 68000

    Joined:
    Oct 25, 2008
    #5
    run coconut battery while your iPhone is plugged in. (not sure what to do if you have a pc as it only runs on OS X. If your battery <95% new I'd return it. Both of our 6s/plus are all at 100%
     
  6. iPad Retina macrumors 6502a

    iPad Retina

    Joined:
    Jan 6, 2013
    Location:
    Canada
    #6
    I had this problem with my 1st Generation iPad. I had left it uncharged for a few months, and it took a long time to charge for some reason. I thought it was dead. But at the end it did turn on.
     
  7. CNeufeld macrumors 6502a

    Joined:
    Nov 25, 2009
    Location:
    Edmonton, AB
    #7
    I suspect the OP got his situation worked out, since this thread is a year old...

    C
     

Share This Page