iPhone 6 plus not sending mms to non-iphone users

Discussion in 'iPhone' started by sk1985, Oct 15, 2014.

  1. sk1985 macrumors regular

    Joined:
    Jan 13, 2006
    #1
    Hi Folks,

    I have an iPhone 6+. I'm currently running the latest iOS and tmobile is my carrier. I'm having issues with mms not sending to non-iOS users. Android in particular. This happens regardless if I'm on wifi or using cellular data. Just wondering if anyone knows how to fix the issue of if you're having similar issues. I know my iPhone 4s had a similar issue once in a blue moon but this happens to every non iMessage i send. I know its happening regardless of what carrier I send a message to.
     
  2. Chatter macrumors 6502a

    Joined:
    Jun 10, 2013
    Location:
    Uphill from Downtown
    #2
    Check settings - cellular - cellular data network.
    The MMS settings should have TMUS for apn under MMS.

    You can reset settings at the bottom of the screen and see if that makes a difference. Did you use a new sim card or old? You may also need to call TMo and ask them to dump you off the network and then add you back on.
     
  3. sk1985 thread starter macrumors regular

    Joined:
    Jan 13, 2006
    #3
    Sadly I do have TMUS. If it helps no of the parties were former iMessage users. I'm the only iphoner in the fam.
     
  4. Fantasigraphic macrumors 65816

    Joined:
    Mar 25, 2009
    Location:
    TN
    #4
    In Settings app scroll down to Messages and see if MMS is turned ON

    Also while at it make sure SMS option is ON as well
     
  5. skierbri10 macrumors member

    Joined:
    Sep 25, 2009
    #5
    I can not send a picture and text to my parents who have s5's on T-Mobile. I have att. I have to send the pic then send the text separately. Been that way since they got smartphones.
     
  6. Chatter macrumors 6502a

    Joined:
    Jun 10, 2013
    Location:
    Uphill from Downtown
    #6
    Sorry, dont know what to tell you other than calling Tmo. This sucks.

    Last try - Google TMo mms settings and edit them yourself. See if that makes a difference.
     
  7. steponeman macrumors member

    steponeman

    Joined:
    Jun 13, 2015
    #7
    You have to check if MMS option is enabled or something like that, iphone is the best yet it still have some bugs
     
  8. NYJJ99, Aug 25, 2015
    Last edited by a moderator: Aug 25, 2015

    NYJJ99 macrumors newbie

    Joined:
    Aug 25, 2015
    Location:
    New york
    #8
    I ham having an issue with my iPhone 6 plus. Updated to current version. I can send to iPhone users and android users no problem. All my setting are correct with simple mobile under cellular data. In fact all was working fine until a few days ago. It's funny it's only to android users. I send an MMS and it says NOT Delivered. But , they get the picture message.! Everyone on android says they get the message but , on my end it says not delivered. It's annoying. How can I fix this? Anybody else have this issue ? I mean I'm not complaining that it works but, just keeps saying not delivered on my end.
     
  9. NYJJ99 macrumors newbie

    Joined:
    Aug 25, 2015
    Location:
    New york
    #9
    I am having the same problem. I can't figure it out. Please someone help. This is annoying
     

Share This Page