iPhone 6 stuck on connecting to router

Discussion in 'iPhone Tips, Help and Troubleshooting' started by apomarinov, Dec 9, 2014.

  1. apomarinov macrumors member

    Joined:
    Feb 8, 2013
    #1
    iPhone 6, 8.1
    TP Link Router
    No such problems till I got this router.
    When I enter password an click Join, the keyboard hides and the UI stays stuck on that view. Then I close and open settings, I`m presented with the WiFi selection view again. What I see is it doesnt event connect enough to check if the password is correct or not, just hides the keyboard and that`s it.
    However the iPhone 4 I have connects with no problem, and the 6 connects fine if there is no wireless protection.
    Tried resetting iPhone`s Network Settings, changing the Wireless Security type of the router, upgrading it's firmware, and whatever other setting I tought might change something. No change.
    I settled to using no protection on the WiFi and just filter the MAC Addresses of the connected devices. Then I tought why not daisychain my old router(with which the iPhone 6 connected fine) to my new one for my other room. I reseted its settings, and set it up just like I've done everytime, and I don't know why but the 6 started doing the same thing with this router too.

    I`m fine with just filtering the mac addresses, but after the 6 doing the same thing with the old router I decided to share and see if something comes to mind to anyone out there :)

    p.s. I`m curious if restoring the phone would make it work, but not right now, and since the old router starting doing the same I dont think the whole fault is in the iphone
     
  2. rigormortis, Dec 9, 2014
    Last edited: Dec 9, 2014

    rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #2
    this is a good tip , its a little known tip. but if you have tried everything , and your only course of action is to erase / replace the router , and you are at your wits end, it might help


    when a wpa or wpa 2 device connects to a wifi router it does not send your password. what it sends is its hash that is calculated by combining the SSID (the name of your router ) and its passphrase.

    i posted abut it on amazon back in the kindle keyboard days, and those jerks deleted my post because they thought i was giving out my wifi password

    i had this problem with the amazon kindle. it wouldn't connect to an airport extreme and amazon was telling people that the router was not compatible

    go to wireshark ( https://www.wireshark.org/tools/wpa-psk.html ) , nothing is saved so you don't have to worry. this code runs on your computer. and not on their server.

    give it your SSID ( your network name ) and your wifi passphrase. it will spit out the pre shared key.

    forget the network you are having issues with
    give it the pre shared key you calculated from wireshark instead of the passphrase.

    it might help. and it might solve your problems.

    for example
    my network name is "netgear" and my password is testest. i can either join the wifi network by typing testest or i can use the preshared key of
    289d98492877cff6f7e0600e3b76fb56b276f0767f74bb40fecbd805e8719558

    they are both the same thing.

    the problem is sometimes the client and the access point can't connect to each other because of a math error.

    email that long hash to your iPhone or iMessage or save it in notes. don't waste your time trying to actualy type it. you can copy and paste it.
     
  3. apomarinov thread starter macrumors member

    Joined:
    Feb 8, 2013
    #3
    That's interesting, I'm going to give it a try when I get home, thanks!.
     
  4. roththet macrumors newbie

    Joined:
    Feb 25, 2015
    #4
    if jailbroken device, Check if u install some tweaks that might be the cause of it

    THis exactly the same things happened to me the last few day, I did everything like reset network setting, reboot, soft reboot, disable wifi networking, reset router, reboot router. I was about to Restore my IPhone 6 as a last resort, but sth come into my mind cuz my device is a jailbroken, and so then I try to reboot into safe mode and the problem not exist there, i was so happy... Therefore, I figured out that it was because of the a tweak. I tried to remove tweak one by one and test. ***At Last, I found the cause of this wifi issue: unable to join any network with password protection and stuck after entering password.
    It's a tweak call RotatePlus( rotate+).My good day is back after disable this tweak and problem was gone.
    I hope this would be a help for u cuz ur issue was exactly like mine...
    - First let try to boot in safe mode and see if it work there
    - If it works, then it's not a hardware failure, it's must be softwares.
    - If urs is a jailbroken device , then there u go, just remove rotateplus, or if u dont have it, try to remove other tweaks cuz tweak is the main cause of this such problem:):):)
     
  5. apomarinov thread starter macrumors member

    Joined:
    Feb 8, 2013
    #5
    Hmmm, seem to have not gotten back and post that I found the problem, and guess what.. Yeah it was this same ********** tweak :) I too figured, wait a minute, why don't I go into safe mode and try it? And it worked :)
     

Share This Page