Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Wanted797

macrumors 65816
Original poster
Oct 28, 2011
1,389
2,825
Australia
I'm having the weirdest problem with my iPhone 6 that doesn't seem to make sense.

I noticed when I first bought it and was setting it up I wasn't able to set up Touch ID while it was plugged into my iMac. I am using the Apple Leather Case in black which I think might be causing part of the issue.

When I plugged the phone into iMac, Laptop or power with the case on, the Touch ID sensor will not work. It's almost as if there isn't one there. It just doesn't respond.

I've been to Apple twice, both times the sensor started working while I was at the genius bar with the case on (both to laptop and power outlet), the first time we had no explanation. The second time the guy suggested it could be the electrical current in my house and static going back down the line from some other appliance. He suggested trying the phone on my Macbook while it was on battery power. I have tried that and it still doesn't work.

However, heres the weirdest part.

If I take the Leather case off the touch ID works fine in my house while plugged in, to laptop, iMac or power. No issues. As soon as I put it back on it stops. I just noticed on my Macbook if I touch the Aluminium body, it works.

Now this makes me think it's a grounding issue with the current and the leather case is stopping that form happening with the phone.

But why then would it work with the case on at the Apple store???

Should I be demanding a replacement/refund? I've only had the phone 1 week (not even).

(Another thing I noticed was I went to a friends and it wouldn't work when plugged in either, however I know that he has had power issues in his house in the past.)

:confused:
 
  • Like
Reactions: Ameliaan

maflynn

Moderator emeritus
May 3, 2009
70,083
38,537
Bring it into the store and explain the situation and then show them why its not working while plugged in. If its a new phone, I say exchange it
 

maka344

macrumors 68000
Nov 4, 2009
1,981
1,143
London, UK
This used to happen with my 5s... Never found out why.

Not tested with my Plus as I never need to charge it at work or during the day.
 

Gav2k

macrumors G3
Jul 24, 2009
9,216
1,607
Seen this on several 5s's. The cause was unearthed computers.
 

Wanted797

macrumors 65816
Original poster
Oct 28, 2011
1,389
2,825
Australia
Issue was discovered to be bad power at the home. (This was suggested by the genius bar tech). I moved house and as he predicted my issue went away.
 

Caleb_Turner

macrumors newbie
Jul 13, 2016
4
0
I have been looking for a solution forever! The solution is that you have to use an apple power block while charging! Totally fixes the problem!!!
 

heyyitssusan

macrumors 68040
Feb 9, 2014
3,533
7,001
This happens to my 6S too.. but the funny thing is it only happens when I use a certain outlet. When I charge it next to my bed at night, everything works fine. In another room, doesn't wanna work at all.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.