iPhone 6 Wi-Fi Problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Saif23, Sep 21, 2014.

  1. Saif23 macrumors regular

    Joined:
    Sep 14, 2014
    #1
    Does Anybody's iPhone 6 Wi-Fi Automatically Turn Off But Wifi Is On But Its Not Connected. No Network Would Show Up But Wi-Fi is Turned On ? I Gotta Do A Reboot For It To Connect
     
  2. vertigomhs macrumors member

    Joined:
    Jul 13, 2008
    #2
    yea just noticed this on my plus today, pretty annoying.
     
  3. Phone nutter macrumors newbie

    Joined:
    Sep 13, 2014
    #3
    I had the same problem at home , my wife's 5s wifi perfect , iphone 6 won't show any network ? Only way I could get wifi back on was to reboot .
     
  4. aleni macrumors 68020

    Joined:
    Jun 2, 2006
    #4
    Yes. I think it's iOS 8 bug. Damn apple, better release the fix soon because it's so annoying. I dont need to reboot to fix this, just wait a little while longer and the connection is back again but tends to lose again after a while.
     
  5. Saif23 thread starter macrumors regular

    Joined:
    Sep 14, 2014
    #5
    I Called Verizon Wireless & They Said It Might Be iOS 8. They Said If Apple Releases An Update & It Fixes It Then We Good But If The Update Don't Fix It, Its A Hardware Problem
     
  6. menist macrumors regular

    menist

    Joined:
    Jun 10, 2010
    #6
    My iPhone 6 Wifi flickers from Wifi to LTE every minute or so. Very annoying, fix with a restart but not permanently.
     
  7. iPhone1 macrumors 65816

    iPhone1

    Joined:
    Apr 2, 2010
    Location:
    San Diego, CA
    #7
    Having Wi-Fi issues as well with both a 6 and a 6+.
    Restored from iCould on the 6 but setup the 6+ as a new iPhone.
    Similar problems on both. I have a 10-month old Motorola dual-band AC router which I have reset numerous times now. Pretty sure it's not the culprit. Have too many things using both channels to turn one off but it may be due to some iOS 8 bug dealing with dual band wifi.

    I used both the 2.5 and 5Ghz bands with my iPhone but neither seems to hold a connection for more than a day before it needs to be forgotten and re-added.

    Very annoying. Hopefully its a bug and not a hardware issue.
     
  8. aleni macrumors 68020

    Joined:
    Jun 2, 2006
    #8
    Please let this be a software bug. Because my iphone 6 has a wifi issue but not my retina ipad mini with ios8.
     
  9. CaptMarvel macrumors 6502a

    CaptMarvel

    Joined:
    Sep 20, 2014
    Location:
    North Carolina
    #9
    edit your network settings from WEP to WPA2 or vice versa.
     
  10. jettie1767 macrumors 6502

    Joined:
    Oct 29, 2003
    Location:
    New Jersey, USA
    #10
    Encountered this wifi issue with my 6+ over the weekend and today. Wifi isn't connected and it doesn't come up with the wifi list. Had to reset to get it to work. Other devices at home are fine. 5S, iPad Air and iPad Mini are all working fine.
     
  11. Trebuin macrumors 65816

    Trebuin

    Joined:
    Jun 3, 2008
    Location:
    Okinawa, Japan
    #11
    I should have had the best opportunity to show poor wifi performance with a ASUS repeater on 5Ghz passing through the main Apple router, but after several tests on Ookla's speediest, I see a solid 50mbps download, but a bit more variance in the upload...should be solid 5 and I see it bouncing all over the place. The actual performance is excellent off my phone. Be aware that the test is impacted by the location, one location could have poor upload or could be hammered. I'll see if I can post my result.

    Also, considering it drop off, I would see a performance hit as I have very little cell reception, not enough for any internet connection, cell only.

    I should also say that the router is configured like this:
    Cable modem--LAN--> Apple Extreme -- 2GHz N-->Asus -- 5GHz AC --> iphone
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      141.5 KB
      Views:
      55
  12. aleni macrumors 68020

    Joined:
    Jun 2, 2006
    #12
    No need to change router settings. Disable your cellular data while you're on wifi fixes this issue for me.
     
  13. mainomega macrumors 6502

    Joined:
    Jun 5, 2007
    #13
    Doing a restore and setting up the phone as NEW are the only things that worked long term for me. Takes a bit more work setting up the apps again but its working fine now, before it would always connect but the speed was aroudn .02 mbps.
     
  14. gowanis macrumors 6502

    Joined:
    Sep 22, 2007
    #14
    Having the same problem over here (iPhone 6). Every so often wifi does not show any networks when many are available. Reboot fixes the problem.

    Anyone know if 8.0.2. has fixed this? I was waiting to get some feedback before doing the update.
     
  15. kissfan macrumors regular

    kissfan

    Joined:
    Dec 7, 2011
    Location:
    Florida
    #15
    No, 8.0.2 did not fix the problem. my iP6+ still drops my G-network. My N-network runs just fine.

    My iPad3, iP5 are both on 8.0.2 and WiFi is fine. It's an iP6(+) hardware issue.
     
  16. mainomega macrumors 6502

    Joined:
    Jun 5, 2007
    #16
    I had this issue for the first time today (on 8.0.2). Came to work and even though WIFI was ON, it didn't find networks. Rebooted phone and it connected and found all 4 networks in my area.
     
  17. gowanis macrumors 6502

    Joined:
    Sep 22, 2007
    #17
    spoke to Apple support today.

    They had me do a "Reset Network Settings" and also did an ios diag (had to click on a link and they were able to get some data from my phone).

    Now its a wait and see if it works.
     
  18. lsmith9523 macrumors newbie

    Joined:
    Sep 22, 2014
    Location:
    Atlanta, GA
    #18
    I received my new 6 plus yesterday. My Wifi keeps dropping off and LTE kicks in. This is in my home, where everything else has perfect wifi coverage. I have to check my iPhone every 10 mints or so, as to not, unknowingly, cut into my data. The only way I can get the phone to reconnect is to toggle off the wifi and toggle back on. Something is not right...
     
  19. JDP1970 macrumors member

    Joined:
    Sep 18, 2014
    #19
    Had this happen twice on my 6 plus now - WiFi signal dropped at home whilst on the 5G network & searching, no available networks in WiFi list (normally at least 8) yet, my old iPhone 4 running on the N network has a full signal. Re-booted phone & problem solved - easy fix but, annoying all the same. :(

    Both occasions have occurred since I upgraded to IOS 8.02. My Wife upgraded to IOS 8.02 within the same hour & thus far, her iPhone 6 plus has not suffered this issue.
     
  20. gowanis macrumors 6502

    Joined:
    Sep 22, 2007
    #20
    Try a "Reset Network Settings". Seems to have worked for me.
     

Share This Page