iPhone 6s - Carrier recognized, but "No Service"

Discussion in 'iPhone' started by nyzwerewolf, Jun 27, 2017.

  1. nyzwerewolf macrumors regular

    Joined:
    Jul 11, 2007
    Location:
    Long Island, NY
    #1
    Greetings folks,

    I have an iPhone 6S that is showing "No Service" even though Settings > General > About shows Verizon 28.4 as the Carrier. Phone > Contacts also shows my phone number.

    The same SIM works on my iPhone 6 without any issues.

    Here are few things I have tried:
    1) powered-off, reseated the SIM, powered-on
    2) reset network settings
    3) reset all content and settings
    4) restored the iPhone from the latest iOS 10.3.2 ipsw using iTunes Restore feature.

    I have pretty much tried most of the possible software fixes. While I am capable of replacing the internals from part suppliers such as ifixit, I am not advanced enough to perform any soldering type of work. Any suggestions?
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.

Share This Page