iPhone 6S Syncing with older macbook

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jweber88, Oct 2, 2015.

  1. jweber88 macrumors newbie

    jweber88

    Joined:
    Oct 2, 2015
    #1
    I am not sure if it has already been asked/answered, but I have a friend who recently purchased an iPhone 6S for his wife. They have a macbook 2007 running OS X 10.6. In order to backup and sync her existing with iTunes they need the current version of iTunes which only runs on 10.8 or later. They tried installing 10.8 and were told it is not compatible with their laptop. Is there a workaround to get them somewhat up to date like installing lion (10.7) and then mountain lion (10.8) or something else entirely different? I want to help them really bad and feel helpless!
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #2
    I have a 2006 MBP (17") running 10.6.8 and two phones with iOS 9.

    But since my MBP has an Intel chip I also have Windows 7 Pro installed. That's my workaround. I boot into Win7 and use iTunes in Win7 to sync with my phones.

    Snow Leopard will handle XP, Vista and Windows 7. If you have a spare copy of one of those operating systems lying around you can install it via Bootcamp in the Utilities folder. The Snow Leopard DVD will have the Bootcamp drivers which will let the hardware of the Mac function with Windows. Then just install iTunes (after you've updated everything) and you should be able to sync.
     
  3. gMacbookPro macrumors member

    Joined:
    May 16, 2010
    Location:
    NYC
    #3
    use iClould backup if no other ways.
     

Share This Page