iPhone 7+ Bluetooth Issues?

Discussion in 'iPhone' started by chunology, Sep 28, 2016.

  1. chunology macrumors 6502

    Joined:
    Sep 16, 2014
    #1
    Anyone having issues with Bluetooth on their iPhone 7+? My audio will randomly cut out during podcasts/playing music and won't play through bluetooth (both headphones and car) until I disable bluetooth, re-enable bluetooth and reconnect the device to the audio output source.

    Has anyone else had this issue? Is my unit defective?
     
  2. CoriG macrumors 6502

    Joined:
    Jun 7, 2011
    #2
    I have had short disruptions while playing music both in my car and on bluetooth headphones.
     
  3. chunology thread starter macrumors 6502

    Joined:
    Sep 16, 2014
    #3
    Thanks for your reply. Could you elaborate on your disruptions, please? Is it to the point where you have to repair your device in order for the audio to work properly?
     
  4. NickYanakiev macrumors member

    Joined:
    Sep 12, 2016
    #4
    I have problems with bluetooth as well....I can connect to about 60-65% of the accessories I have tried so far. The rest are simply not "seen"...
     
  5. reverberlayed macrumors regular

    Joined:
    Sep 5, 2014
    #5
    Both bluetooth and CarPlay have been giving me a little bit of trouble with my iPhone 7 plus. I was playing music via bluetooth yesterday for few seconds and then all audio cut out. I looked at the phone and it was showing the song as still playing. If I turned BT off and then back on, it would pair the phone and pay a few seconds of music again and stop. Then I tried CarPlay and it wasn't recognizing a connection. I restarted the phone and tried BT again, only for the same result - it would play a few seconds then lose connection. After the restart CarPlay has been working normally. I also tried rebooting my car's audio system which didn't work.

    I don't know if the bluetooth & CarPlay issues are related, but it's worth noting. I will try delete my iPhone profile from the car and re-pair when I get out of work and see if that solves anything.
     
  6. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #6
    There is no quick solution to the Bluetooth problems. Scroll down to view a couple other threads describing the issue. Apple has been notified and there are many complaints in the Apple forums. For now don't use the audio connection. It will also disconnect the phone connection! Hopefully an IOS update can fix this.
     
  7. chunology thread starter macrumors 6502

    Joined:
    Sep 16, 2014
    #7
    This is the exact same problem I'm having (minus the CarPlay). Interesting. Thank you for the post.

    Thank you for this, I'll scroll and read the other posts.
     
  8. tekchic macrumors 65816

    tekchic

    Joined:
    Apr 19, 2010
    Location:
    Phoenix, AZ
    #8
    My MPow Swift bluetooth earbuds are having intermittent issues as well. Turn them on (already paired) and they show up on the iPhone icon top bar, but no music plays through them.

    Lately I've had to reboot them multiple times and even re-pair, and then the next time I go to turn them on, same thing again -- music plays through phone speakers instead of the paired headphones. Super annoying when I'm rushing to head out the door for a run.
     
  9. jtwlbz macrumors 6502a

    Joined:
    Dec 23, 2014
    #9
    Bluetooth problem on my 16 BMW... hope Apple fixes it within 2 week otherwise i have to return the phone.
     
  10. CoriG macrumors 6502

    Joined:
    Jun 7, 2011
    #10
    The music will come in and out. Last night I was working out with bluetooth headphones and the music would pause for about a second and resume playing
     
  11. SaveUsBatman macrumors member

    SaveUsBatman

    Joined:
    Jun 2, 2015
    Location:
    Phoenix, AZ
    #11
    Yeah I've been having issues on my iPhone 7 Plus, iOS 10.0.2 installed, in my car. I have bluetooth headphones but I haven't had an issue with them like I do in my car.

    Now in my car, 2014 Nissan Altima, I have issues where
    - The audio will speed up almost like it's trying to catch up, this normally only happens when I'm streaming over LTE. Downloaded all my iCloud library to my phone thinking it would fix it, no dice.
    - The audio will lag in and out and this is normally the one that happens right before it's about to drop.
    - The audio will play for a good while maybe like 5 min-10 min and then just drop completely. My 7 Plus will say it's playing the music still, and show it's connected to my car, but there is no audio coming through.

    I used an iPhone 6s Plus and iPhone 5s this past month both on iOS 10 betas and official and both did not have this issue.
     
  12. Flyers12 macrumors newbie

    Joined:
    Oct 12, 2011
    #12
    I'm one of the users with issues especially st the gym, I just replaced the phone and still have issues. So here's hoping it's not hardware but maybe they switched the Bluetooth controller and its interfering more often. I have no idea but it can get infuriating. So much for wireless is the future, I really want this to work but I'm being discouraged.
     
  13. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #13
    Looks like Apple figured out a way to get the AirPods to work at the expense of everything else. :(
     
  14. Feenix macrumors member

    Joined:
    Aug 7, 2015
    #14
    iPhone 7+ having Bluetooth issues in my 2013 Ford Explorer. Works a while, gets choppy, and only Airplane Mode/reconnecting will get any audio back to my car. Don't have bluetooth headphones but I assume the same outcome.
     
  15. slappypig macrumors member

    slappypig

    Joined:
    Jun 26, 2015
    Location:
    Earth
    #15
    iPhone 7+ - no issues yet with Bluetooth in either my car or my other bluetooth devices (Skullcandy Ink'd, Phonak Compilot and Beats Pill). I've had the 7+ for about 4 days now so not a lot of extensive testing...

    I will add that during iOS 10 beta testing on my iPhone 6 I had intermittent issues with my Compilot being connected then there would be zero sound - no phone calls, no music, etc...I would typically have to turn off the Compilot and turn it back on for it to start working properly again...
     
  16. longpath macrumors member

    longpath

    Joined:
    Apr 21, 2003
    #16
    My iPhone 7 drops connectivity with my Polar V800 while syncing data, at about a 3 to 1 ratio, and requires a circuitous process to get the sync started that was never a problem with my 5S. It's not an iOS 10 issue, as the 5S saw regular use with every version from developer beta 4 through to 10.0.1 final, without ever having an issue. The 7, on the other hand, requires the watch to initiate a pair and sync, which requires 10 button pushes to get to, as opposed to the standard sync, which required only 1. Even after I get the connection going, it drops with the 7, and requires multiple attempts before it can complete the sync.

    I am stuck waiting for a firmware update for my V800 to bring up its Bluetooth to the same spec as the 7, and it's become tedious enough that I am seriously considering demoting my V800 to race and heavy training duty, and replacing it for daily use with a Series 2 Apple Watch.
     
  17. KCWolfPck macrumors regular

    Joined:
    Jun 21, 2007
    Location:
    Fredericksburg, VA
    #17
    I appear to be having issues as well. Yesterday was my first day with my new iPhone (7+ JB 256). I connect to a Bluetooth speaker while at work (Bose Soundlink Mini II). After I paired my new phone, the audio kept skipping....kind of like it was a weak signal that kept connecting/disconnecting when you get too far away. I thought it might be a slow internet connection (I was streaming satellite radio), but the issue persisted even when playing music from the internal player. When I put the phone directly next to the speaker, the issue seemed to be less apparent. Additionally, I had a heck of a rough time pairing the new iPhone with my Bragi Dash wireless headphones.

    I actually chatted with Apple tech support and they recommended that I exchange the phone. I've since learned that it was a common issue. I hope it is software related and can be fixed via an update.

    My wife's iPhone 6 (10.0.2) is now having difficulty playing Bluetooth audio in her Acura RDX, so that leads to the hope that it is a software issue and not something inherently wrong with the 7+.
     
  18. dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #18
    Exactly! I've always said wired is more reliable (like wired headphones!) yet everyone argues that wireless is the future. Like I've posted here many times...name ONE wireless technology that is faster and more RELIABLE than it's wired replacement!

    This sucks about BT because I also use BT in my car to listen to music while driving. I wish Apple would get JUST ONE iPhone's WIFI and BT correct on release.

    I just got my 7 Plus yesterday so maybe mine will be good, but not holding onto hope too tightly.
     
  19. karebare518 macrumors member

    Joined:
    Mar 21, 2008
    #19
    I'm having the same issues with all my Bluetooth headphones. They all worked fine on my 6s plus. Trying to decide if I should return the phone or do you guys think a software update will fix the issue?
     
  20. tekchic macrumors 65816

    tekchic

    Joined:
    Apr 19, 2010
    Location:
    Phoenix, AZ
    #20
    I'm hoping a software update will fix it -- some people on iPhone 6's have reported issues after installing iOS10. So not sure if it's the hardware or iOS10. I'm down to one bluetooth earbud set that will connect when I turn them on (Anker). My other pair (MPow Swift) only connects when I do a re-pair *every* single time, and when connected, I can't game w/them as the sound lag is at least a second or more behind the action.
     

Share This Page