iPhone 7 LTE issues - T-Mobile

Discussion in 'iPhone' started by bsdbytes, Sep 29, 2016.

  1. bsdbytes macrumors newbie

    Joined:
    May 26, 2009
    Location:
    Ohio
    #1
    Anyone on T-Mobile still seeing any LTE issues with their iPhone 7 and the 25.2 carrier update? I've had the phone for about a week and reception hasn't been as solid as my iPhone 6+. Also, download and upload speeds have been worse to abysmal where the 6S performs well. Today the phone lost service and it required a power cycle to get back on the network. This is in an area with solid service. The four tests in the screenshots were taken while holding 2-3 bars. Other times, the test fails saying it can't reach the server.
     

    Attached Files:

  2. JoeyD74 macrumors 6502

    Joined:
    Oct 31, 2014
    #2
    Look in the trouble shooting section you will see a thread on it, its mainly Verizon in it but the symptoms are exactly what your describing.
     
  3. Ghytty macrumors newbie

    Ghytty

    Joined:
    Sep 29, 2016
    #3
    My iPhone 7+ on T-Mobile is constantly disconnecting from Lte. I've been trying to solve the issue with T-mobile and Apple for several days now. I constantly have to put the phone into airplane mode and back out to use the internet.
     
  4. Snot Rox macrumors 6502

    Snot Rox

    Joined:
    Sep 16, 2014
    Location:
    SF Bay Area, CA
    #4
    Mine has been working great. I have a dead spot in my room where my 6+ never got reception and with my 7+ I get 2-3 bars LTE.
     
  5. Lancetx macrumors 68000

    Lancetx

    Joined:
    Aug 11, 2003
    Location:
    Texas
    #5
    My 7 has been no better or worse than the typical T-Mobile service in my area has allowed for the past year now. I'm still hitting the same good and bad spots and notice no difference between it and the 6s+ that I had before.
     
  6. Mewang macrumors newbie

    Mewang

    Joined:
    Dec 28, 2016
    #6
    Hi did you ever get this solved?

    I'm having the same issues. I keep getting disconnected to 4G from LTE. If I put airplane mode on and off it turns on again. Is this a T mobile issue or my IPhone 7 issue?
     
  7. bsdbytes thread starter macrumors newbie

    Joined:
    May 26, 2009
    Location:
    Ohio
    #7
    I returned mine. The report by Cellular Insights describes the issues I was experiencing when looking at the Qualcomm vs Intel iPhone 7.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    I'm on T-Mobile carrier setting 27.1 and LTE is solid and very fast on my 7 plus.
     

Share This Page