iPhone 7 - No SIM Card Installed message

Discussion in 'iPhone' started by AppleDogs, Apr 7, 2017.

  1. AppleDogs macrumors newbie

    Joined:
    Mar 5, 2017
    #1
    I have a new iPhone 7 that has given me the No SIM Card Installed message 3 or 4 times now. The first time, the message went away when I power cycled the phone. This worked once or twice. The next time, I ejected the SIM after powering off/on didn't work. This last time, powering off/on did not work so I ejected the SIM again.

    Is this normal?

    EDIT - Is this an issue with the phone or the SIM?

    I have not even used the iPhone 7 except for a few minutes here and there to set up options, etc. It has otherwise sat on a table. I have handled it for less than an hour since I bought it in the middle of February. The phone is gift for an elderly relative so I don't want her to have to eject the SIM all the time.

    I bought an iPhone 7 Plus the same day as the iPhone 7 and have never encountered this message.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Try to pop out the sim tray and reseat the SIM card.
    If it still does it get the sim replaced.
    If it does the same with a new sim bring it to Apple to get a replacement phone.
     
  3. AppleDogs thread starter macrumors newbie

    Joined:
    Mar 5, 2017
    #3
    Two of the three/four times I got the message, I did eject the SIM and reseat it in the try. I just started writing down when it happens to keep track.

    How often would be considered "normal"? It's just weird since the phone hasn't even been moved or handled much.
     
  4. Stewie macrumors 6502

    Stewie

    Joined:
    Jan 6, 2004
    Location:
    Austin
    #4
    Normal would be zero times.

    Get a new SIM card and if it still happens take the phone in to be looked at.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    It's not normal.
    I never had my iPhone display no sim while the sim is in.
    Get the SIM card replaced next by your carrier.
    Then test it again to isolate the issue.
    Defect could be with the SIM card or the phone itself.
     
  6. Relentless Power macrumors P6

    Relentless Power

    Joined:
    Jul 12, 2016
    #6
    I would start by going to your carrier and they will give you an immediate SIM card replacement right there. And then you can test it in front of them and then go from there if it's the Sim card itself or the iPhone. Which in your case, if it is the iPhone, then they're able to verify the issue when you're directly in front of them.
     
  7. jetsam macrumors 6502

    Joined:
    Jul 28, 2015
    #7
    I've had five different iPhones over 8 1/4 years. I have never seen the "No SIM Card Installed" message.
     
  8. JackieInCo macrumors 601

    Joined:
    Jul 18, 2013
    Location:
    Colorado
    #8
    I had either a 3G or 3GS that did this. Apparently this was a known problem with many of them.

    My 5S sometimes takes inserting and ejecting a sim once or twice to get it to be read but it never flashes no sim once the card is read.
     

Share This Page