iPhone 7 phone call issues related to Continuity

Discussion in 'iPhone' started by mk313, Jun 21, 2017.

  1. mk313 macrumors 6502

    Joined:
    Feb 6, 2012
    #1
    We have two unlocked iPhones 7's that have given us nothing but issues on the phone side since we got them. We are on Sprint & although Sprint has it's issues, we have had way more problems with these phones than with any others that we used prior (iPhone 5s, iPhone 6, iPhone SE).

    The main issue is that when you answer a call, the other person can't hear you. I would always have to say Hello twice when answering calls, as the first one was never heard. Sometimes they would hear the second Hello, sometimes not.

    After months of playing around with settings, etc. I finally found the culprit: the continuity feature that allows me to answer calls on my other Apple devices. Once I turned that off, everything works perfectly.

    I'm wondering if anyone else has had this issue? If so, have you figured out a way to resolve it so you can use continuity? It's hard to tell if this is a Sprint issue or an Apple issue, but I'm certain that if I talk to Sprint, they'll say it's Apple & if I talk to Apple they'll say it's Sprint. Since I've not had this problem on any other iPhone, and it is now an issue on both 7's, I'm fairly certain it's an issue with the phones themselves, but I'm also pretty sure that replacing them won't fix anything, as the chances I got two bad iPhones is pretty remote.

    I can live without the feature if I have to, but if someone else has had this same issue & found a way to fix it, I'd love to have it back.
     
  2. jc0187 macrumors member

    Joined:
    Apr 10, 2017
    #2
    My dad always jokes with me, saying things like "I've got an old flip phone and no one has problems hearing me or me hearing them. You have a nearly $1000 phone that, whenever you call, I CAN NEVER HEAR YOU! Go and buy this same, $20 flip phone so I can hear you ". OP, I don't think you are the only one. My wife complains that when I'm talking to her, it sounds like I'm trying to talk over someone crunching up tin foil or plastic, or cellophane. She says it's pretty bad sometimes. Don't know if it's my reception or just the phone. Anyways, how do I disable this Continuity you speak of? Oh, also I have the 7 as well.
     
  3. mk313 thread starter macrumors 6502

    Joined:
    Feb 6, 2012
    #3
    You can turn continuity (for calls) off by going to settings -> Phone ->Calls on Other Devices. Make sure the slider is set to off.
     
  4. jc0187 macrumors member

    Joined:
    Apr 10, 2017
    #4
    What are the draw backs to turning it off? I do have an Apple Watch, however, call quality freakin sucks on it, so I never use it anyways.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  6. mk313 thread starter macrumors 6502

    Joined:
    Feb 6, 2012
    #6
    I'm not an expert on this, so I may be missing something but I don't believe so. The downside would be that you can no longer answer/make calls through your Mac/iPad/iPad. I'm not sure if it would change your watch of not. I know that the watch works pretty closely with the phone, so you might lose the ability to answer calls on your watch too. Those are the only real downsides that I'm aware of to turning it off.
     

Share This Page