iPhone 7 Plus, 6s Plus, Bluetooth Issues

Discussion in 'iPhone' started by TugboatFred, Oct 3, 2016.

  1. TugboatFred macrumors newbie

    Joined:
    Sep 28, 2016
    #1
    Is anyone else experiencing major Bluetooth issues with the iPhone 7 Plus, 6s Plus on iOS 10.0.2? It's beginning to be a major problem. My Bluetooth headphones that worked perfectly well on iOS 9 are having total routing issues with my headphones on iOS 10.

    They'll route completely randomly (sometimes through the phone, other times through the headphones, and a lot of times through nowhere.) The only resolution is trying over and over again, pairing and unpairing, then trying to open up apps in one order or another to get it to work. I've factory reset the phone, I've updated it. Still no resolution.

    It's incredibly annoying when you're trying to head out somewhere and Bluetooth is what slows you down. Sometimes it takes up to ten minutes to get this crap to work.

    Does anyone have a resolution for this or am I stuck with an OS, phone, whatever that is Bluetooth deficient until an update rolls out? And no, the airpods don't work for me. I already lost one hitting a bump on the motorbike. That ended that foray.
     
  2. brianric macrumors regular

    Joined:
    Jul 30, 2011
    #2
    I'm having major issues with Bluetooth on my iPhone 7 Plus. Hard to tell if it's the phone or IOS 10, as it was noticed roughly at the same time. I can't connect to a Bluetooth dongle that communicates with my Valentine One Radar Detector. I can't make a call on my phone in the car through the hands free setup unless I have Car Play engaged, IE the phone is connected to the USB port. If I have my phone disconnected from the USB port and I receive or make a call the phone goes into private mode and either locks up or the call goes through the iPhone.
     
  3. tekchic macrumors 65816

    tekchic

    Joined:
    Apr 19, 2010
    Location:
    Phoenix, AZ
    #3
    Yes, for one of my cheap earbuds (Mpow Swift). The Anker earbuds (still cheap but a little better), seem to work more consistently.

    My Mpow Swift (which I really loved before iPhone 7+) had a long battery life and paired easily, connecting whenever I turned them on. Now with iPhone 7 and 10.0.2, I have to force "Forget this device" and re-pair them every single time I want to use them, then launch Spotify to see if it "picked them up" since it says "Connected" but still plays through the speakers. I've basically just left them on my desk at work now.

    If Apple wants to ditch the 3.5mm, sure, great, whatever. But don't mess up Bluetooth worse than it was before. All my Bluetooth earbuds worked beautifully with iPhone 6+ / iOS pre-10. Guess I'll be buying their $159 earbuds later this month if I want to have a consistently solid pairing/running set. :/
     
  4. auero macrumors 65816

    Joined:
    Sep 15, 2006
    #4
    My 7 Plus has issues with streaming audio to my car. It speeds up songs and cuts in and out randomly.
     
  5. cwawak macrumors newbie

    Joined:
    Jul 7, 2010
    #5
    Call Apple, open a support ticket. Complaining on Macrumors does not give enough visibility.
     
  6. AhemThisGuy macrumors member

    Joined:
    Sep 9, 2016
  7. brianric macrumors regular

    Joined:
    Jul 30, 2011
    #7
    That's all well and good, but right now I'm jammed solid in photo shoots for the month of October and I don't have time to dick around with Apple support until November. I only posted to see if others are having Bluetooth issues.
     
  8. TugboatFred thread starter macrumors newbie

    Joined:
    Sep 28, 2016
    #8

    And that's my problem. The AirPods don't fit whatsoever on me. So now my $800+ motorbike helmet with integrated Bluetooth speakers doesn't work as it used to which so thoroughly pisses me off.

    If they had custom fitment it might make more sense, but to break it so thoroughly...
    --- Post Merged, Oct 4, 2016 ---
    Had similar issues. I can't tell if it's iOS 10 or my iPhone. Before I call Apple Support and they run me through the gamut I just want to nail down which is the issue.
     
  9. brianric macrumors regular

    Joined:
    Jul 30, 2011
    #9
    Problem I'm worried about before I call Apple Support is Apple will blame Honda, Honda will blame Apple. There isn't a question Apple is to blame, as my 6S Plus with the last version of IOS 9 had no problems. I wish I still had my 6S Plus so I could at least narrow it down to the IOS 10.
     
  10. brianric macrumors regular

    Joined:
    Jul 30, 2011
    #10
    Just got off the phone with Apple Support. I was told to back up iPhone , then do a restore of the IOS, then restore my backup. Oh Goody, spend the next few hours restoring my apps, map data, etc. I don't think this will fix the problem but I'll give it a try.
     
  11. tekchic macrumors 65816

    tekchic

    Joined:
    Apr 19, 2010
    Location:
    Phoenix, AZ
    #11
    Ugh - that sounds like you got handed something off a support call script. It would be wonderful if it worked, but I really don't think it will. Keep us posted. :(
     
  12. psac macrumors 6502a

    psac

    Joined:
    Jul 6, 2009
    #12
    I'm having the same exact issue. It's iOS 10. I never had a problem (besides the normal skipping) with my iPhone 6 and my AYL bluetooth headphones, and now I have it about once a week. I had it this morning, and like someone said, it took about 10 minutes of shutting down and restarting both devices repeatedly to finally get it to work. I'm using all the same hardware, just now with iOS 10.0.2. I do NOT have any problems with streaming bluetooth audio to my car, only to the headphones.

    The funky thing is that the headphones connect and still control the iPhone (will play the music), but the music plays externally from the phone itself and not the headphones. The people on the bus really love that one.
     
  13. mlpsponzischeme macrumors regular

    Joined:
    Jun 16, 2009
    #13
    My headphones use to work great. Now the music stops playing sporadically with my iPhone 7. I thought it was my headphones until I saw that other people are having issues. I really hope they fix this. This sucks!
     
  14. brianric, Oct 4, 2016
    Last edited: Oct 4, 2016

    brianric macrumors regular

    Joined:
    Jul 30, 2011
    #14
    Support person mention going to next tier if it doesn't work. I told Apple Support I'm on a down day, then I have five straight days of photo shoots so I'm not going to be able to troubleshoot after today until a week next Thursday at the earliest.
     
  15. SaveUsBatman macrumors member

    SaveUsBatman

    Joined:
    Jun 2, 2015
    Location:
    Phoenix, AZ
    #15
    Same here. Oddly enough it's just my car as my bluetooth headphones have not done this to me. So a part of me wanted to blame my car, but now seeing as it's more widespread, I'm going with blaming iOS 10 and hoping that they are working on a fix.
     
  16. brianric macrumors regular

    Joined:
    Jul 30, 2011
    #16
    Did a backup, then restore of IOS 10.02, then restored backup, which was time consuming as 30 apps need updating, reinstall my various maps and restore purchases on map apps, then un-pair then re-pair Apple Watch. Two plus hours of my life wasted. Took car out for a spin, still cannot make a phone call using hands free on the car unless the phone is connected to the USB port. The only good thing that came out of this is my phone now connects to the Bluetooth dongle that communicates with my V1 Radar Detector. I'm presently with tech support second level to try to find out what's going on.
     
  17. 03sho macrumors 6502a

    Joined:
    Sep 19, 2007
    Location:
    UK
    #17
    Before iOS 10 my 6s plus would connect to my car and play music instantly. Now it takes about 1 minute to connect. Not a big issue but still annoying.
     
  18. brianric macrumors regular

    Joined:
    Jul 30, 2011
    #18
    I have a friend call me on his 6S with IOS 10, no problem using hands free on his 2014 Chevy Silverado. That leads me to believe the problem is in the iPhone 7 Plus itself. I even called Honda Technology and reset the deck, still can't connect unless plugged into the CarPlay USB port with Car Play running.
     
  19. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
    #19
    My 6S+ was having issues with 10.0.2 But, since I updated to 10.1 Beta 2 ( dev account ) it's been geeat once again. I can now pair and consistently communicate with my V1 dongle, and BT with the car stereo (2013 Acura TL and 2012 M5 ) Although, even now, my Note 7 connects much quicker over BT !
     
  20. SaveUsBatman macrumors member

    SaveUsBatman

    Joined:
    Jun 2, 2015
    Location:
    Phoenix, AZ
    #20
    Gah, this makes me wanna install 10.1 Beta 2 lol.
     
  21. brianric macrumors regular

    Joined:
    Jul 30, 2011
    #21
    Same here, but I no longer want to beta test.
     
  22. ancpratt macrumors member

    Joined:
    Sep 21, 2016
    #22
    I'm having issues with mine as well, especially while streaming music in the car. It cuts in and out there numerous times during every drive and randomly. I don't recall any playback issues while using the wired ear buds; just over Bluetooth. I suspect iOS 10.0.2.
     
  23. TugboatFred thread starter macrumors newbie

    Joined:
    Sep 28, 2016
    #23
    Just as an update: I was traveling in my car today on business in the city and the directions completely cut out for me due to Bluetooth. It's illegal to use your phone while driving, so in a city I had no knowledge of, I had no turn-by-turn navigation. Had to pull over to the side of the road, do the whole pairing and unpairing thing, which still didn't work for too long.

    So I bust out my BT headphones in an attempt to circumvent the car -- no luck. Really getting irked that I upgrade my phone and an essential function breaks. I get it: there will be bugs. But such a crucial feature ought to have those ironed out (like in iOS 9).

    Apple support gave me the same runaround as mentioned above. I spent two hours today wiping, restoring, etc. Tried mine and my wife's Bluetooth headsets, still issues with routing.

    Cannot believe I am about to say this: I may return the 7 Plus and use the 6S Plus on iOS 9. It's kind of ludicrous.
     
  24. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
    #24
    That sucks! If you're gonna do the 6S thing..don't wait too long.. I turned in my 7+ for the 6S+ ( 3 days ago ) and it came pre-loaded with iOS 10!
     
  25. MetalMatt24 macrumors regular

    MetalMatt24

    Joined:
    Dec 18, 2012
    #25
    I just got a 7 plus and the Bluetooth in my new truck works buts it's laggy and slow
    Wasn't like that on my 6s Plus no lag at all
    I'm
    Rather annoyed with this new iPhone 7
     

Share This Page