iPhone 7 Plus - Has this happened to anyone?

Discussion in 'iPhone' started by Jayson A, Oct 31, 2016.

  1. Jayson A macrumors 68000

    Joined:
    Sep 16, 2014
    #1
    So my iPhone 7 Plus has been working fine for the most part. I was using it normally earlier today, then I set it down for a bit and did some work. Then the strangest thing happened...

    I picked up my iPhone 7 to unlock it like I always do, and pressed the home button. The haptic made the click-feel, but my iPhone didn't go home. At first I thought, okay, that was weird. So I set it back down again, the screen went black as usual. Then, I picked it back up and hit the home button again... still nothing, but I got the click-feel haptic feedback. So then I tried using the power button to wake the phone instead of "raise to wake" and the power button didn't even work!

    So now I'm starting to panic... what's going on? I used raise to wake once again to get my screen to turn on and swiped to the left to open camera. This is when the camera started freaking out and wouldn't focus on anything. It would go blurry, then focus for a second, then go blurry (as if I just opened the app) then it would try to focus again and go blurry again. At this point, I wanted to see if the phone even worked at all, so I tapped the photo preview icon and looked at a couple of photos. It let me zoom around and look at several photos, so I thought... okay, my phone is working.

    Then, I went back to the camera and BOOM, it was working again. So I tried one more time at clicking home and this time it WORKED. So I messed around for a bit double clicking the home button, changing the volume, locking and unlocking the phone... it seemed like it was working again, but just to be safe, I restarted the device by holding power and volume down.

    It seems to be working fine now, but I wonder what the heck it was doing while it was freaking out and not responding to button presses.
     
  2. silverblack macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #2
    I had a similar issue yesterday. I didn't have raise to wake option enabled. So the screen stayed off the entire time, but gave the haptic feedback when pressing the home button, except screen stayed off. Power button didn't do anything either. Finally, I plugged in the power from lightning port, it woke the screen and everything started working again.
     
  3. Jayson A thread starter macrumors 68000

    Joined:
    Sep 16, 2014
    #3
    Thanks! Perhaps something in the system was hung up for whatever reason and not letting the phone respond to any input.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
  5. Jayson A thread starter macrumors 68000

    Joined:
    Sep 16, 2014
    #5
    Ironically, I heard about the update AFTER my phone freaked out. It's updated now, but it wasn't updated when it was freaking out.

    Maybe the update was downloading in the background automatically??? It happened around the time that the update came out.
     

Share This Page