Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

chekz0414

macrumors 6502a
Original poster
Jul 3, 2011
770
99
FL
So I recently have noticed this odd issue with the iPhone 7 I have, sometimes the speaker 'Pops' and then doesn't come back until you restart the iPhone? I also had an odd issue with the camera sometimes opening up black and then not showing a live preview? Then when I quit the app and do it again the preview loads then blurs out? So I restarted the iPhone and then the camera was fine again...has anyone else noticed these oddities?
 
  • Like
Reactions: _mdiaz10

chscag

macrumors 601
Feb 17, 2008
4,622
1,946
Fort Worth, Texas
Unless gremlins have infiltrated your phone, I would say you have a defective iPhone 7+. Return it to Apple or your carrier (whoever you bought it from) and have them swap it out for a new one.
 

Janders91

macrumors member
Jun 23, 2015
51
49
Granite Falls, NC
So I recently have noticed this odd issue with the iPhone 7 I have, sometimes the speaker 'Pops' and then doesn't come back until you restart the iPhone? I also had an odd issue with the camera sometimes opening up black and then not showing a live preview? Then when I quit the app and do it again the preview loads then blurs out? So I restarted the iPhone and then the camera was fine again...has anyone else noticed these oddities?

My speaker has done this twice. But after restarting the device after I heard the speaker "pop" it goes away.

Could this somehow be software related? I haven't had the camera problem

If it matters, I have 7+ Jet black running iOS 10.1 beta
 

Slimmyhendrix

macrumors regular
Sep 14, 2014
245
27
MN
this is SW related I'm almost certain. Ive had this issue on our Hardware components for work only to find in the software it was doing a speaker check (usually on startup or when opening an app that plays sounds). Coding changed and never happened again.
note: this was android based tablet system
 
  • Like
Reactions: Janders91

Janders91

macrumors member
Jun 23, 2015
51
49
Granite Falls, NC
this is SW related I'm almost certain. Ive had this issue on our Hardware components for work only to find in the software it was doing a speaker check (usually on startup or when opening an app that plays sounds). Coding changed and never happened again.
note: this was android based tablet system
My gut is saying it's software related too.

Time will tell I guess
 
Last edited:

blaine07

macrumors 68020
Nov 14, 2014
2,496
2,454
Oklahoma
6S+ here, done the speaker deal described above many times. Restart fixes it, id almost bet has to be software related issue.
 

Rcpd34

macrumors newbie
Oct 29, 2016
1
0
So I recently have noticed this odd issue with the iPhone 7 I have, sometimes the speaker 'Pops' and then doesn't come back until you restart the iPhone? I also had an odd issue with the camera sometimes opening up black and then not showing a live preview? Then when I quit the app and do it again the preview loads then blurs out? So I restarted the iPhone and then the camera was fine again...has anyone else noticed these oddities?

I'm having both issues.
 

_mdiaz10

macrumors newbie
Oct 31, 2016
1
0
So I recently have noticed this odd issue with the iPhone 7 I have, sometimes the speaker 'Pops' and then doesn't come back until you restart the iPhone? I also had an odd issue with the camera sometimes opening up black and then not showing a live preview? Then when I quit the app and do it again the preview loads then blurs out? So I restarted the iPhone and then the camera was fine again...has anyone else noticed these oddities?
I've just got my iPhone 7 a week ago and I just noticed that too for my phone I turn up or down my volume and the sometimes it like pops 1-2 time and then goes silent to fix it I have to restart my phone.. I hope it's a software thing.
Has anyone permenatly fixed this problem ??
 

micqo

macrumors regular
Oct 9, 2014
139
63
I noticed my jetblack 128gb gave some POP effect when choosing message sound, but when I choose same "song" to ringtones the phone didn't gave any POP - odd! Sounds like software bug for me. :confused:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.