iPhone 7+ question

Discussion in 'iPhone' started by Edge1978, Oct 10, 2016.

  1. Edge1978 macrumors 6502

    Joined:
    Sep 11, 2011
    #1
    I just picked up an iPhone 7+ over the weekend and I am loving it. However I've only had to charge it once since Sunday morning, which I had no issues doing so. However today when I was charging it I received a message "This accessory may not be supported" which I found odd because I am using an apple iPhone charger. While it was plugged in i decided to do a hard reset. And the message didn't appear again.
    However it seems like it is taking FOREVER to charge, it was sitting at 89% for the longest time. So I took out the charger and did another hard reset without the charger in this time and when it rebooted it jumped up to 94%. So I plugged in the charger once again did another hard reset and when it rebooted it was back tp 89%.

    I remember reading that a hard reset with the charger will give the most accurate reading. However with it showing 2 different amounts, I am not sure what to do. Anyone else have this happen?
     
  2. Edge1978 thread starter macrumors 6502

    Joined:
    Sep 11, 2011
  3. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
  4. silverblack macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #4
    If you could reproduce the error message, go to Apple Store, and demonstrate it. They will probably first give you new charging accessories to test. If issue remains, they will replace your iPhone.
     
  5. Lizzie W. macrumors newbie

    Lizzie W.

    Joined:
    Sep 13, 2016
    Location:
    FL
    #5
    Oh man, get it replaced if you can. This same thing happened with my first 9.7" iPad Pro. It was fine to charge twice, and on the third time I got the same error about the accessory being unsupported (it was the charging cable that came in the iPad box). I left the iPad plugged in and it charged maybe 5% in 6 hours. I Googled the problem and checked the port for dust or debris that could be interfering with the lightning connector--found nothing there. I did two hard resets and a restore via iTunes and neither fixed it. I don't have any third-party cables, but no Apple cable I tried would work. I'm convinced something was wrong with the charging port or battery. I was within my return window and exchanged the iPad for a new one, and it works like a charm in every way.

    Good luck to you!
     
  6. Edge1978 thread starter macrumors 6502

    Joined:
    Sep 11, 2011
    #6
    Thanks everyone. I was advised to do a reset and that seemed to fix the issue with the charger.
     
  7. dobssy macrumors newbie

    Joined:
    Sep 24, 2016
    #7
    Something similar happened to me too. Pay attention the cable might be faulty.
    What happened to me was when I was connecting my Iphone to my macbook , it would rapidly connect/disconnect.
    The charging was fine in the power adapter but not in the macbook.
    Turned out the cable was bad.
     

Share This Page