iPhone 7 Wifi Woes

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Uglybloke, Dec 12, 2016.

  1. Uglybloke macrumors newbie

    Joined:
    Dec 10, 2016
    #1
    Hi.

    I've had my iPhone 7 for about 4 days, and I'm having wifi troubles.

    At home over the weekend, I connected the phone to my home wifi no problems - however, whenever I leave the house and return home, I have to manually go into the settings and select the network. The iPhone remembers the password, but I have to select it each time. Slightly annoying.

    Then today, while at work, I connect to the BT Wifi Hotspot using my BT Broadband login details, something I had to do every time I picked my phone up! The phone kept dropping off the network. It didn't do it whilst I was using the phone, only if I locked it for a period of say, 20 minutes or more. I would have to reconnect to the network, again, selecting it manually (it wouldn't pick it up automatically).

    The issue at home isn't a big deal - although I'd like to know why it's doing it, as my old mobile (Samsung Note 4) didn't do this.

    The issue at work - I'm thinking could be a DHCP lease issue, although I sometimes connect my laptop to the network, and the lease on that doesn't expire for 4 hours. I'm thinking that because I'm locking the phone, it loses the IP address?

    Anyway - question is - is it hardware related, and is there a fix for it - or is it router related?

    Sorry for the wordy post - thanks in advance.
     
  2. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #2
    Did you setup the phone from a backup or as new?
     
  3. Uglybloke thread starter macrumors newbie

    Joined:
    Dec 10, 2016
    #3
    As new...
     
  4. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #4
    Have you tried Settings/General/Reset/Network Settings?
     
  5. Uglybloke, Dec 13, 2016
    Last edited: Dec 13, 2016

    Uglybloke thread starter macrumors newbie

    Joined:
    Dec 10, 2016
    #5
    Nope, I'll try that now, cheers.
    --- Post Merged, Dec 13, 2016 ---
    No luck, still drops the connection every time I lock the iPhone.

    Actually - it does drop the connection, but then maybe 2 or 3 seconds later it picks it up again. Not the sort of behaviour I'd expect, but could be because it's an open network - it's workable, thank you.
     

Share This Page