Iphone 8+ doesnt airdrop to el capitan?

Discussion in 'iOS 11' started by saudor, Nov 10, 2017.

  1. saudor macrumors 6502

    Joined:
    Jul 18, 2011
    #1
    Has anyone been able to air drop from an 8 plus to a mac running el capitan? My ipad air 2 does it fine and handoff works fine between ipad, iphone 8+ and el capitan. Both idevices are running 11.1

    I tried it with other macs also running el capitan and it doesnt work. The same mac when booted into sierra works perfect with airdrop.

    Ive done the usual trouble shooting like signing in and out and airdrop to "everyone" - no good.

    Also iCloud tabs on ios11 devices dont show up in el capitan safari either.

    Thanks!
     
  2. WolfSnap macrumors 6502a

    WolfSnap

    Joined:
    Sep 18, 2012
    Location:
    SoCal
    #2
    Perhaps, if you weren't running two year old versions of MacOS, and upgraded to the latest (free) version, things would work as expected.
     
  3. saudor thread starter macrumors 6502

    Joined:
    Jul 18, 2011
    #3
    A software I use doesn’t work on Sierra. Apple supports two OS X versions so I’m not missing out on security either
     
  4. WolfSnap macrumors 6502a

    WolfSnap

    Joined:
    Sep 18, 2012
    Location:
    SoCal
    #4
    High Sierra & Sierra are supported.

    El Capitan is before Sierra.

    Pretty sure it's not supported.
     
  5. Mr_Brightside_@ macrumors 68020

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
    #5
    I'm not sure if this is a bug or a 'feature' wanting you to be on the latest OS.

    I just tested AirDrop between my mini on el cap and SE on 11.1, and it worked ok. However, my iCloud tabs do not work with my personal Macs on Yosemite, and cellular calls don't work either :(
     
  6. saudor thread starter macrumors 6502

    Joined:
    Jul 18, 2011
    #6
    Pretty sure It’s supported.
    https://support.apple.com/en-ca/HT201222



    Yeah it’s weird. My iPad Air 2 on ios11 work fine but not the iPhone (I’m guessing it’s the same with any ios11 device like X and 8)
     
  7. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #7
    AirDrop has been having quite a few problems with iOS 11 for me.

    In iOS 10 they got it perfect (again for me) with near 100% reliability. However after iOS 11 its been "flakey" at best between my iMac (High Sierra) and friends and family. I'll go to AirDrop someone a pic and everyone in the room except the person that I want will pop up.

    I've reported a ton of bugs and talked to tech however I can't find a way to replicate specifics. It will just work or it just wont, sometimes I'll see device or person I want to send something to pop up and vanish before I can tap on it/them.

    Its frustrating for sure. I wouldn't be surprised if it works (to El Cap) but its just bugging out.
     
  8. saudor thread starter macrumors 6502

    Joined:
    Jul 18, 2011
    #8
    yeah i noticed that too. it takes a few tries to get it going.
    As for 8+ and El cap.. maybe it has something to do with BT5.0 that's on the phone. The Air2 with the Bt4.0 on ios11 works fine.
     
  9. ballookey macrumors newbie

    ballookey

    Joined:
    May 2, 2004
    #9
    Similar issue: At work My co-worker is fully updated to High Sierra, but because of a software issue he experienced, I have never updated my computer past El Capitan. (sigh, one day...)

    I just got an iPhone 8+. Previously I was able to use AirDrop to all the office Macs on my iPhone 6SE, but since switching to the 8+, I can only AirDrop to other phones or my home computer which is logged into my iCloud account.

    My coworker OTOH is using an iPhone 6+. He's been able to AirDrop to all the office computers until he installed iOS 11. Now he can't AirDrop to his High Sierra Mac or my El Capitan Mac.

    So to sum up:

    iPhone 8+ on iOS 11 can't AirDrop to El Capitan or High Sierra computers *except* home computer with same iCloud account logged in.

    iPhone 6SE on iOS 10.whatever could AirDrop to everything.

    iPhone 6+ on iOS 10.whatever could AirDrop to everything.

    iPhone 6+ updated to iOS 11 can only AirDrop to other iOS 11 phones, but not to El Capitan or High Sierra computers.

    So, super small sample size, but based on that it seems like iOS 11 is the problem. It's the only common denominator between my coworker and me.
     
  10. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #10
    Airdrop requires certain BT hardware on the Mac (as well as the iPhone), perfectly possible to be running EC on a Mac where the BT hardware won't support the later iPhones with iOS 11, I have a 2011 MBP running HS, no Airdrop will work to any iPhone running iOS 11 (or 10 for that matter).
     
  11. saudor thread starter macrumors 6502

    Joined:
    Jul 18, 2011
    #11
    I've airdropped to el cap 2014-2015 macs and it's still the same deal. Booting to the sierra partition on both of mine brings back airdrop (+icloud tabs) so it's something apple changed on the BT stack of 8+ (and possibly the 8/X)
     
  12. csurfr macrumors 6502a

    Joined:
    Dec 7, 2016
    Location:
    Seattle, WA
    #12
    I might be mistaken, but isn’t there a compatibility mode for older versions? I could swear that I saw it once before...
     

Share This Page