iPhone activated but no service

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ian-frs, Jul 11, 2008.

  1. ian-frs macrumors 6502

    Joined:
    Apr 12, 2007
    Location:
    Jax
    #1
    I was able to activate my phone but no matter what I try my phone will not give me any reception. I tried turning off all the push services and still nothing. Did a complete restore and nothing. Any ideas on how to get my reception.
     
  2. Island Dog macrumors 6502a

    Island Dog

    Joined:
    Sep 11, 2005
    Location:
    St. Cloud, FL.
    #2
    Same thing here. Just keep seeing "no service". I just don't know what to do at this point.
     
  3. atacinus macrumors 6502

    Joined:
    Oct 25, 2003
    Location:
    New York City
    #3
    I was in this same boat - it was a SIM card problem...took it back to the AT&T store where the swapped out the SIM and did something on their computer networks and now it works.
     
  4. ki2594 macrumors 6502a

    Joined:
    Apr 12, 2008
    Location:
    Carmel, IN.
    #4
    yeah thats what i have...my old sim still works on my old fone. WTH DO I DO...i need it tonight
     
  5. hcoteen2008 macrumors regular

    Joined:
    Jul 2, 2008
    Location:
    Texas
    #5
    Call AT&T and tell them you need to know what SIM card is registered to your account. Then just pop out the SIM card that came with your new iPhone and tell them that number and have them switch it. My iPhone works now because of that. :D
     

Share This Page