Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iPhone always connects to neighbors Wifi

Rufuss Sewell

macrumors 6502
Original poster
Jun 25, 2010
277
192
Austin, TX
For some reason my iPhone always connects to my neighbor's wifi despite it being a far weaker signal than my own wifi.

I sometimes go over there so I don't want to forget their network, I just want my iPhone to prioritize my far faster and stronger wifi.

I've tried changing my network to a name that starts with an "A" to make it come first alphabetically but that's had no effect.

Any clues what to try next?
 

Vundu

macrumors 65816
Jun 10, 2009
1,428
497
Manchester, UK
For some reason my iPhone always connects to my neighbor's wifi despite it being a far weaker signal than my own wifi.

I sometimes go over there so I don't want to forget their network, I just want my iPhone to prioritize my far faster and stronger wifi.

I've tried changing my network to a name that starts with an "A" to make it come first alphabetically but that's had no effect.

Any clues what to try next?

Different channel on your wifi?
 

alFR

macrumors 68030
Aug 10, 2006
2,516
547
For some reason my iPhone always connects to my neighbor's wifi despite it being a far weaker signal than my own wifi.

I sometimes go over there so I don't want to forget their network, I just want my iPhone to prioritize my far faster and stronger wifi.

I've tried changing my network to a name that starts with an "A" to make it come first alphabetically but that's had no effect.

Any clues what to try next?

Try changing the preferred network order on your Mac (System Preferences > Network > Advanced) so that your network is above the neighbour's one in the list: that should make all your devices try your network first (the preference syncs across your devices via iCloud IIRC). If you don't have a Mac, try forgetting your neighbour's network, join your own one, then pop over so you're in range of their network and connect to it again: that might have the same effect. There's no way to look at the list of preferred networks and reorder them on iOS, unfortunately.
 

sunking101

macrumors 604
Sep 19, 2013
6,710
1,870
For some reason my iPhone always connects to my neighbor's wifi despite it being a far weaker signal than my own wifi.

I sometimes go over there so I don't want to forget their network, I just want my iPhone to prioritize my far faster and stronger wifi.

I've tried changing my network to a name that starts with an "A" to make it come first alphabetically but that's had no effect.

Any clues what to try next?
Why not forget their network because surely you could pick your own up from their place?
 

Rufuss Sewell

macrumors 6502
Original poster
Jun 25, 2010
277
192
Austin, TX
Why not forget their network because surely you could pick your own up from their place?

I go over there pretty often and my signal is weak/useless there.

It's close enough on both sides to connect, but they are both super slow when connected at the wrong house.
 

ielessar

macrumors regular
Apr 29, 2015
217
58
WJ
In addition to what the poster above me said, when connected to your neighbor's WiFi, "forget it" so that your iPhone does not connect to it automatically.
 

sunking101

macrumors 604
Sep 19, 2013
6,710
1,870
OP doesn't want to do that. Wants to be able to connect when @ neighbors
Make a note of the neighbour's WiFi password in the Notes app and type it in each time he wants to connect. Then 'forget' the network when back home. This is a unique case and I can't think what the OP would want to use WiFi at his neighbour's for on such a consistent basis.
 

Hunk4u

macrumors member
Oct 16, 2015
32
2
Hyderabad
Y
For some reason my iPhone always connects to my neighbor's wifi despite it being a far weaker signal than my own wifi.

I sometimes go over there so I don't want to forget their network, I just want my iPhone to prioritize my far faster and stronger wifi.

I've tried changing my network to a name that starts with an "A" to make it come first alphabetically but that's had no effect.

Any clues what to try next?

Most of the networks needs passwords to get connected and few doesn't! When you go under the WiFi settings, you can see an option called "forget". Click on it and you're done :)
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
50,509
18,830
Y


Most of the networks needs passwords to get connected and few doesn't! When you go under the WiFi settings, you can see an option called "forget". Click on it and you're done :)
Seems like the very post you are quoting and replying to specifically says that the option to forget the network is known about but isn't something that they want to use.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.