iPhone and Exchange 2007

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kevingurney, Oct 22, 2010.

  1. kevingurney macrumors newbie

    Joined:
    Oct 22, 2010
    #1
    Hi all.

    I've just taken delivery of the first of the company iPhones and am now trying to get it to synch with our Exchange 2007 server....and getting a "unable to verify account information" error.

    We currently have OWA available on the internet (although it doesn't have a certificate in place and so gives a certificate error when accessing via https).

    Within Exchange, ActiveSync and OWA are both enabled.

    I've tried the whole OWA URL as the server name (https://exchange.ourdomain.com/owa) as well as the external IP address plus the internal server name and internal address with the iPhone connected via VPN but still get the same error.

    Any suggestions would be appreciated.
     
  2. dbendixen macrumors member

    Joined:
    Oct 22, 2010
    #2
    At my previous company, I had the very first iPhone in the company and got it working with Exchange 07 without issue. I think all I did was select exchange, put in my email address and password, and then when it came up, entered the domain as mail.mydomain.com. If Exchange is setup properly that's all you should have to do. Oh, and make sure you only use the first part of your email (before the @ sign) as the username. If none of that works, you may have something wrong with your Exchange setup. Call in the Pros!
     
  3. kevingurney thread starter macrumors newbie

    Joined:
    Oct 22, 2010
    #3
    And there's the problem.....I am the Pros !!

    Have this iPhone ahead of the company abandoning Blackberry to move to Apple and need to get it sorted before O2 ship the rest of the handsets.

    My understanding is that the iPhone syncs to OWA. OWA is working apart from the certificate error but I've tried different permutations of the server name but still get the "Unable To Verify Account Information" error which is becoming annoying now !
     
  4. Btrthnezr3 macrumors 6502a

    Btrthnezr3

    Joined:
    Aug 5, 2010
    Location:
    Texas
    #4
    Hey... I had the same error come up...I just said ok, or whatever to let it keep going instead of delete or cancel.

    Once I did that, I closed mail app, (make sure it's gone, even on multitasking bar if you use that)...I then closed all other apps and restarted.

    Once I got back on, it worked---the error was virtually meaningless for me.

    Another coworker got her exact phone setup through our system with no error, but the error came up with mine... My IT dept was stumped. We deleted and tried everything again and still got the error--I selected the option to keep going aka didn't care and to keep going through the process. Once I did that and restarted as I told you earlier, it worked.
     

Share This Page