iPhone and Gmail

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cycocelica, Jan 16, 2008.

  1. cycocelica macrumors 68000

    cycocelica

    Joined:
    Apr 28, 2005
    Location:
    Redmond, WA
    #1
    Ok so I want my Gmail email to be forwarded to my phone but I also want to keep a copy in my gmail inbox. I thought I had it setup like that but evidently not. What are the settings I need in order to accomplish this?
     
  2. FunkyJunk macrumors regular

    FunkyJunk

    Joined:
    Oct 17, 2007
    Location:
    Leesburg, VA, USA
    #2
    My settings, which seem to work fine for me:

    IMAP Account Information
    Name: [whatever]
    Address: [youraddress@gmail.com]
    Description: [whatever]

    Incoming Mail Server
    Host Name [imap.gmail.com]
    User Name [youraddress@gmail.com]
    Password [yourpassword]

    Outgoing Mail Server
    Host Name [smtp.gmail.com]
    User Name [youraddress@gmail.com]
    Password [yourpassword]
     
  3. leetard macrumors newbie

    Joined:
    Nov 14, 2006
    #3
    Upgrade

    I was using the above method but the 1.1.3 upgrade fixed this...

    You can select gmail from the list of email clients and it incorporates the imap. Just make sure that you select "enable imap" from your gmail settings on your computer first.
     
  4. Vegantnt macrumors newbie

    Joined:
    Sep 23, 2007
    #4
    this is just a warning in case you don't already know:

    Gmail is capable of both POP3 and IMAP

    Pop3 will give you duplicates of your emails. Which means deleting them on your iPhone means that original is still in your inbox. So logging in to your gmail from safari will let you really delete files, or to retrieve an email you deleted by accident.

    IMAP is a mirror of your inbox. So all your mail programs that are set to IMAP will reflect changes in the others. No syncing required.
     
  5. coma macrumors newbie

    Joined:
    Dec 9, 2006
    #5
    ok this is a separate issue but here goes, my iphone is set to sync with my mac's gmail with pop3-enabled features in my apple mail. the weird thing is that the inbox in my iphone's mail app shows my "sent" messages from my mac's gmail account. is there anyway i can fix this?
     
  6. Vegantnt macrumors newbie

    Joined:
    Sep 23, 2007
    #6
    unfortunetly if there is a way I haven't heard about it. The reason it does this is because gmail keeps a copy of your sent messages. Since pop3 mirrors everything it shows you that copy. I don't know if gmail has the option but maybe you can turn off its ability to save sent messages. That may fix it
     
  7. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #7
    It's a known "feature" of using POP3 with GMail. The best suggestion would be to switch to using IMAP rather than POP3 on both your iPhone and your Mac: Collecting from multiple devices using POP3 and GMail can have other "interesting" side effects with Gmail so that's another good reason for switching over. IMAP is far, far better at handling multiple devices and you also get all your labels as IMAP folders
     
  8. nsilva macrumors member

    nsilva

    Joined:
    Jan 16, 2008
    Location:
    RI
    #8
    I didn't look hard enough to check, but remember than you can set POP3 in gmail settings so that when you check your mail outside anywhere from gmail it will delete that message in gmail (Makes things real easy for me when I am looking at stuff on my iPhone, then the Mail in iMac, then on the MacBook, then in the gmail website, or even anywhere else! Its just so much more organized.)
     

Share This Page