iPhone and Mio Digiwalker (GPS) Bluetooth Issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by joker3dx, Dec 28, 2007.

  1. joker3dx macrumors newbie

    Joined:
    Dec 28, 2007
    #1
    I just recieved the Mio Digiwalker c520 for Christmas, it is nice, but the Bluetooth hands free is problematic with my iPhone.

    I have gotten it to work, with some tinkering, about 4 or 5 times.

    The c520 reads the iPhone everytime, and when you try to connect, asks to set a pin, which I do, and then the iPhone asks for one, which I input. At this time the iPhone says paired, but the c520 times out and doesn't work.

    After this, but only a few times, I can unpair from the iPhone and ask to reconnect, which works, and the handsfree works fine. This has only happened a few times though, as the iPhone says it cannot pair again most of the time, and the c520 always times out and says cannot connect.

    I am so very frustrated!

    To recap:

    iPhone never discovers c520, but once pairing is asked from c520, it reads it. (c520 is bluetooth discoverable and has been tested with many other phones)

    c520 read the iPhone, but never completes the connection process.

    When the iPhone will try to connect to the c520 there is great success! But this rarely happens.

    Which one should I throw against the wall?

    Thanks guys.
     
  2. Drumjim85 macrumors 68030

    Drumjim85

    Joined:
    Oct 7, 2007
    Location:
    DFW, TX
    #2
    the iphone's bluetooth isn't really pair-able to anything other than a headset ... it's pretty stupid, but that's what apple has done...

    if you gps unit doesn't work, its normal
     
  3. joker3dx thread starter macrumors newbie

    Joined:
    Dec 28, 2007
    #3
    Gps

    I have read up on this, and I also see that Garmin has an official compatability list, but I am unable to return my model, and resale is never what you paid for it.

    I am just angered, because I have actually gotten it to work before.
     
  4. jorous macrumors newbie

    Joined:
    Jan 1, 2008
    #4
    I have same issue we should cooperate

    I have the same issue and I conntacted mio support and the promised with an update. it has been a month and no sign for update. we need to cooperate if I find a solution I will let you know and vice versa. not sure if it will help to know that iphone does work perfectly with Mio C510. I tried it in one of the shops couple of times.
    maybe the issue is with WinCE 5 as the C510 runs with WinCe 4.2.
    my email is: joseph@nlpuae.net
     
  5. hazza.jockel macrumors 6502

    Joined:
    Aug 2, 2008
    Location:
    in a swag
    #5
    hey
    did you guys ever figure this out?
    I just got a mio digiwalker for free and i cant even locate my iphone with the gps bluetooth or locate the gps with my iphone.
    any help would be appreciated.

    o btw im not sure of the model number.
     

Share This Page