iPhone app store refuses my password

Discussion in 'iPhone' started by Hewhoquacks, Mar 8, 2012.

  1. Hewhoquacks macrumors newbie

    Joined:
    Mar 8, 2012
    #1
    (Skip to the bottom if you don't want to read all the background on the issue I'm having)
    Awhile back, I decided t change my apple ID password for security purposes. I managed to do so with no problems. Later, though, an update showed up in my phone's app store. I told it to update, as normal, and it prompted me for my password, as normal, but then it said I entered the password wrong. So I tried again. Still wrong. I figured I must be having a bad day, and so entered it a 3rd time very slowly and carefully, after which it informed me that my account has been disabled or something and I have to reset my password because it's been entered incorrectly too many times. I didn't know what was going on, so I played along. I went back and reset my password again. After successfully doing so, I went back to get that app update. The same thing happened. I ended up resetting my password a 3rd time. After being told I was still entering it incorrectly in the app store, I decided things were messed up apple somehow broke it. I tried searching online for solutions, and found people with similar problems. Apparently, they all had their problems fixed by going into setting, app store, then clicking on their apple ID to sign out and sign back in with the new password. So I did that too. It didn't work. I think I tried a couple other things, but none of them worked. Eventually I gave up and put it off until I had more time and a greater motivation to research this problem. Now here I am again, on spring break. I haven't tried updating any of my apps, cuz I know it won't accept my password. Everything else has been workign fine, but since I have the time, I figrued I tried it out again. I went back to the app store, entered my password hoping it'd work and there was just some sort of delay on password changes being implemented in the app store or something, but lo and behold, I was told not that I had entered my password incorrectly, but that they suddenly decided to disable my account and I'd have to change my password. It was bullcrap, but I did it anyway. And, go figure, it didn't help at all. Nothign changed. As in, I'd go back to the app store and it still told me my account was disabled upon the first attempt at entering my password. They did'nt even bother telling me I entered it wrong. Yet, I was logged on to the website and in itunes just fine. Everything worked just fin, except for the app store, which claimed my account was disabled. So back to the internet I went searching for answers. I found some stuff, but none of it was helpful. I got tired of trying things and playing with my phone. Apaprently, I can download new apps with absolutely no trouble. I'm not prompted for a password then; they just download/install straight away. Same thing happens if I try to use the itunes store. So I've tried contacting apple to make them sort this out, but they're being difficult and I haven't gotten through. So here I am, posting a sort of rant, hoping someone reads this and has any idea what's going on.
    One point of interest is that when I reset my password, it starts off by asking me for my apple ID. What's interesting is that it's auto-filled in with my apple ID in email format, but it doesn't accept that because that's not my apple ID. So I have to delete the "@*****.com" part before proceeding.

    Tl;dr, Everything works just fine, except the app store on my phone claims my account is disabled. I can't download app updates, and I can't figure out why. Any help would be greatly appreciated.
     
  2. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #2
    Recommend you clean it up into paragraphs that someone can read. :eek:

    Make 'em short and sweet.

    If all else fails contact Apple support.
     
  3. Hewhoquacks thread starter macrumors newbie

    Joined:
    Mar 8, 2012
    #3
    Sorry for the massive block of text. I'm not so great at organizing things into neat little bundles.
    But I actually figured it out (kind of). As I mentioned near the end of the previous post, my phone would occasionally display my apple ID as being in email format instead of just the shorthand. I still don't know what the problem was or how it got to be this way, but I ended up getting on my computer and resetting my password from their main website. This time, I was able to enter my ID in email format, and so I proceeded to change my password. After that, I had to go into the app store on my phone, look at the Featured apps, then scroll allll the way to the bottom where I found another place to log in (apparently separate from the settings menu, the itunes store, and the website). I was able to log in using my email address (again, not my actual apple ID), and then it accepted the new password and everything worked again.
    So, apparently I have two apple ID's that are interchangeable, but require unique passwords. I am so confused.
     

Share This Page