Iphone App Store soooooo sloooooow!

Discussion in 'iPhone' started by Sir Ruben, May 10, 2011.

  1. Sir Ruben macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    Location:
    UK
    #1
    What is everyones general opinion of the app stores performance on an iPhone?

    Back when I had a 3GS the app store would always load instantly and it was an enjoyable experience. These days I find it incredibly slow to load at times (over wifi). Very often clicking a different section such as Featured, or Updates will bring up a pop up saying it cannot connect to the app store. When I switch the wifi off and back on it begins to work again. This routine is beginning to get very tiresome!

    I asked a friend of mine who says she gets the same problem with her iPod Touch and it happens with her on 3 different wifi connections (ruling out a dodgy router).

    I have also noticed a similar issue when browsing, at a random point it will no longer be able to browse, but sliding the wifi option off and then on again resolves the issue.

    I have tried everything from a hard reset, reset network settings, restore the phone to new, you name it Ive tried it. it just seems to be 'how it is'.

    Now very often when people stick up for Apple they use the term "because it just works", however, in the case of the app store, Id have to disagree.
     
  2. The Californian macrumors 68040

    The Californian

    Joined:
    Jan 17, 2009
    Location:
    Surfers Paradise
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    iPhone 3GS here on 4.3.3, and an iPod Touch 2nd Generation on 4.0 and an iPhone 3G on 4.3.2 are all very "snappy" on the App Store.
     
  3. xlost6 macrumors 6502

    Joined:
    Feb 28, 2011
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_8 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8E401 Safari/6533.18.5)

    I have a Verizon iPhone 4 with iOS 4.2.8 that got new this past Sunday and it works snappy and fast for me!!
     
  4. Sir Ruben thread starter macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    Location:
    UK
    #4
    Hmmmm maybe its the N router that I have? I thought iPhone4's played nice with N routers though?
     
  5. The Californian macrumors 68040

    The Californian

    Joined:
    Jan 17, 2009
    Location:
    Surfers Paradise
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    Do you experience the same problem over 3G?
     

Share This Page