iPhone Apps always "Waiting"

Discussion in 'iOS 5 and earlier' started by Anthropogenesis, Apr 28, 2012.

  1. Anthropogenesis macrumors member

    Joined:
    Feb 21, 2010
    Location:
    Paraguay
    #1
    I apologize if this topic has been covered, but I couldn't come up with the proper wording to give me any results.

    I have been having problems with my iPhone lately. A ton of different apps frequently gray out and say "Waiting," as if they are being installed, but they are not. I am not syncing with my computer. I am not even on the same network as my computer.

    It drags my iphone to a halt and makes it impossible to use. Anyone else have this problem?
     
  2. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #2
    Try doing a hard reset: push/hold power and home button at the same time until the white apple shows up. Let go. This may take care of the weirdness. You might need to do it a couple times in a row.

    Otherwise, you may have a rogue app installed. Not all apps play nice with other apps and/or the iOS. If the hard reset doesn't help, try un-installing apps one at a time in reverse order (most recent app should be first to go). Check to see if the problem is still there after each uninstall. Keep going until it disappears and then re-install the other apps - leaving that one off the list.

    BTW - you should do a hard reset after a bunch of changes are made, just to settle things in. So, when uninstalling (or installing) a bunch of apps, stop every once in a while and do a hard reset. It allows your iDevice to catch up.
     
  3. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #3
    I have had my iPad since week one and has never done a hard reset and my iPad works perfectly.
     
  4. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #4
    I had this after I restored my iPhone. Try a hard reset and if that doesn't work you might have to restore your device
     
  5. ya1950, Apr 30, 2012
    Last edited: Apr 30, 2012

    ya1950 macrumors regular

    Joined:
    Mar 29, 2009
    #5
    There is a long thread about this on the Apple Support Forum. This is usually due to a corrupted database file. You can try the following: download iPhone Explorer (free download). Use it to navigate to /var/mobile/Media/Downloads and delete all the files in that folder. You may have to reboot after. That should get rid of the corrupted database file and any partial downloads that did not complete.

    Of course backup before you so this in case anything goes wrong. Restoring as a new phone will do the same thing but restoring from a backup will only restore the corrupted file. Let us know if this helps.
     
  6. Anthropogenesis thread starter macrumors member

    Joined:
    Feb 21, 2010
    Location:
    Paraguay
    #6
    I ended up downloading that program, deleting those files, and then doing a hard restart. I probably should have done one and then the other to isolate what solved it, but either way, it appears to have resolved the issue.

    Thank you guys for taking the time to post these recommendations. I really appreciate it. Saved me a trip to the store.
     
  7. ya1950 macrumors regular

    Joined:
    Mar 29, 2009
    #7
    From my experience with the same problem a hard reset did not work. In any case glad your phone is back to normal.
     
  8. 2sa macrumors newbie

    Joined:
    Mar 10, 2011
    #8
    This thread is very simular to my earlier thread:
    http://forums.macrumors.com/showthread.php?t=1362254

    Right now my phone is no longer searching for the remainder of my items to restore. I lost about 100 pictures.

    Should I complete the steps above and will I have the option for a older back up to restore from?
     
  9. David Hughes macrumors newbie

    Joined:
    Feb 5, 2013
    #9
    Thanks, that worked a treat

    The Iphone Explorer app and deleting the Plist files from the downloads folder worked. Many thanks.
     

Share This Page