iPhone apps won't update

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TeenageMac, Sep 23, 2008.

  1. TeenageMac macrumors newbie

    Aug 26, 2008
    I have been trying to update my apps over the past couple of days and everytime it says it will update next time I connect it to iTunes. I'd love to be able to update directly to my phone. Is this a problem with the appstore, tips, suggestions?
  2. emt1 macrumors 65816

    Jan 30, 2008
  3. Ntombi macrumors 68040


    Jul 1, 2008
    Bostonian exiled in SoCal
    Are you connecting over WiFi, 3G, or EDGE?

    I updated two apps via iPhone a few hours ago, and two days ago.
  4. Opie macrumors 6502a


    Jun 17, 2008
    If it is over 10mb it has to be done on the Comp.
  5. kernel_panic macrumors newbie


    Jun 18, 2003
    I have an iPhone 3G, and I'm constantly having trouble updating apps.

    On the phone:
    1. I click App Store
    2. Use the Updates tab
    3. Click an app
    4. Click the FREE button, then INSTALL
    5. Type in my password
    6. The app appears on my home screen with the loading message
    7. Then, an error pops up saying unable to download - use iTunes.

    In iTunes:
    1. I go to Applications
    2. Updates available link
    3. Click Get Update
    4. iTunes says Purchasing...
    5. Then I get an error saying I've already purchased the item but it hasn't been downloaded.

    Am I doing this all wrong, or what?
  6. Tokenjourney macrumors newbie

    Oct 21, 2008
    I have the same problem with downloading/updating apps directly to the phone. Additionally, when I update apps on the computer and try to download to the phone by snycing, most of the apps will not update. I get an error message. My last attempt to update apps resulted in 13 apps that would not update. I have tried every fix Apple recommends, and the only thing that has worked is to delete the app from the phone and then re-install, which is a pain.

    Any help would be greatly appreciated.
  7. kernel_panic macrumors newbie


    Jun 18, 2003
  8. Paratel macrumors 6502


    Jan 26, 2005
    Somewhere in the US
    Really Solved

    I used to have the same problem, here is a fix. However, if the App is over 10mb you have to update it over wi-fi or though iTunes.

    1. Identify the App you need to update.
    2. Begin installing App on your iPhone.
    3. The second it starts loading the new App, delete the previous App icon from your iPhone.
    4. Once you delete the previous version the updated App will install without the error message or having to connect to iTunes.

  9. Tokenjourney macrumors newbie

    Oct 21, 2008

    Thank you both for the information. I fixed the problem the hard way (deleting the app on my iPhone and then completely re-loading it after updating it) at the time of my last post, and none of my apps have updated since then, but when they do, I'll try these fixes and report the results. Thanks again.
  10. emerzrocker99 macrumors newbie

    Oct 8, 2009

    The Solution Is To Update Your Iphone On Itunes. First Go To Device Then Click Summary(you Should Be There Automaticaly) And Click Check For Update Then You Can Get The Update For The Apps I Found That On My Own Just Today!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Share This Page