iPhone Audio issues (acts like connected to a dock when not connected)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Fried Chicken, Apr 1, 2012.

  1. Fried Chicken macrumors 6502

    Fried Chicken

    Joined:
    Jun 11, 2011
    #1
    So my iPhone acts like it's connected to a dock when in fact it isn't. The issue manifests itself with audio issues from most applications.

    It happens intermittently, and whenever I try to adjust the volume I get something like the screenshot below (notice no volume).

    B/c it's jailbroken I don't want to do a full restore. I already restored it from backup, however that didn't fix the problem. While music is playing and this "issue" happens, the volume bar disappears but the music continues to play.

    This also happens while I'm connected to headphones.

    Any ideas?
     

    Attached Files:

  2. Loredelgado macrumors newbie

    Joined:
    May 4, 2012
    #2
    This is happening to me to... Im desperate please if you find the reason for these let me know!
     
  3. applemessiah macrumors member

    Joined:
    Jul 8, 2011
    #3
    I have had the same problem on two iPhone 4. For awhile I thought it was headphone jack and surprisingly it turned out to be dock connector assembly. I replaced that and phone works like normal again. Good luck!
     
  4. keith777 macrumors newbie

    Joined:
    Sep 25, 2012
    #4
    my problem was no sound it's like connected to a dock. i tried to insert a piece of stick on that hole.... don't push it to deep. and finally the sound came back! seriously it came back... hope ur problem is just like mine... really everything is been restore. I thank God for that wisdom He gave..hope this can help others..
     
  5. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #5
    What hole are you referring too?
     

Share This Page