iPhone Back Up To External Hard Drive OSX 10.14 Mojave

Discussion in 'macOS Mojave (10.14)' started by djtee1, Oct 17, 2018.

  1. djtee1 macrumors newbie

    Joined:
    Oct 17, 2018
    Location:
    Los Angeles
    #1
    Help Please.... Im backing my iPhone X up to my Mac Book Pro using iTunes 12.9. Also Im running Mojave. I watched all the videos on how to get to the "Library" then "Application Support" and then to "Mobile Sync." I then copied the "Backup" folder to my External Hard Drive. I then Erased the "Backup" folder from the Mobile Sync folder. After that I was told to paste something like this:



    ln -s /Volumes/mac1tb\ 1/Backup /Users/djtee1tb/Library/Application\ Support/MobileSync/Backup



    It was created with my external direction as well as my internal HD name. after 100 different variations and then pasting it into TERMINAL I get this:



    "Operation Not Permitted"



    I see older posts where this worked. Is it not working for me because I updated to Mojave? Am I doing something wrong? Im confused. Anyone have any idea how to accomplish this task using Mojave? Thanks in advance.
     
  2. ferbandie macrumors newbie

    Joined:
    Aug 17, 2018
    #2
    I have the same problems, with my older MacBook Pro and High Sierra I could do without problems but now I have the same message "Operation Not Permitted".
    This is the command that I always have used:
    ln -s /Volumes/My\ Passport/iTunesBackup/Backup/ ~/Library/Application\ Support/MobileSync/Backup
     
  3. BLUEDOG314 macrumors 6502

    BLUEDOG314

    Joined:
    Dec 12, 2015
  4. ferbandie macrumors newbie

    Joined:
    Aug 17, 2018
    #4
    I have tried this command with sudo:
    sudo ln -s /Volumes/My\ Book/iTunesBackup/Backup/ ~/Library/Application\ Support/MobileSync/Backup

    I put the password and have the same message: Operation not permitted
     
  5. MSastre macrumors 6502

    MSastre

    Joined:
    Aug 18, 2014
    #5
    Check out iMazing. Let's you do all sorts of things for you iPhone, including backups. I use the free version for importing custom ringtones.
     
  6. BLUEDOG314 macrumors 6502

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #6
  7. Analog Kid, Jan 10, 2019
    Last edited: Jan 11, 2019

    Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #7
    This was making me crazy, but I think I figured it out. Pre-Mojave, I had a symlink to another drive that had been working fine. I changed the name of that drive and the symlink broke. Then there was no way for me to update the symlink-- I kept getting the same "Operation not permitted".

    iOS device backups are stored in ~/Library/Application Support/MobileSync/Backups

    The MobileSync directory must be protected by the operating system to prevent tampering. I can't create a directory called "MobileSync" in the Application Support directory ("Operation not permitted"), but iTunes can. If I let iTunes create it then when I enter that directory in Terminal I even get an "Operation not permitted" when I try to list the directory.

    I could probably solve this by going into Privacy settings and giving Terminal "Full Disk Access", but that seems like a dumb idea.

    Finder seems to be able to manipulate this directory though. So after moving my backup directory to a different drive I went into Terminal and in some other directory (such as ~/) did:

    ln -s /Volumes/NewDrive/Backups Backups

    This created a symbolic link to the new backup directory in a completely useless place. Then I went into finder and dragged that symlink into the ~/Library/Application Support/MobileSync directory.

    I've managed to sync and back up, so it looks like it worked.
     
  8. ferbandie macrumors newbie

    Joined:
    Aug 17, 2018
    #8
    Thanks, I will try
     
  9. harriska2 macrumors 6502a

    harriska2

    Joined:
    Mar 16, 2011
    #9
    Thanks! Works like a charm. If the external drive crashes, I'm not sure I can get to it but at least I have the devices backed up somehow (not cloud).
     
  10. foliage macrumors newbie

    Joined:
    Aug 18, 2018
    #10
    I managed to work around this the other day.

    Simple solution may be to go to system preferences > security & privacy > privacy > full disk access > unlock lock to make changes > add terminal app

    Hope that helps.
     
  11. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #11
    This would reduce your overall security level just to make this one change.

    You could presumably revoke full access later, but that doesn't seem like any less effort than dragging and dropping the link.
     
  12. foliage macrumors newbie

    Joined:
    Aug 18, 2018
    #12
    True - I revoked access straight after the terminal command. I'm not sure what you mean by dragging and dropping the link but I dragged the desired destination folder into terminal for the command pathway. Took a minute to do. Best of luck.
     
  13. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #13
    I meant the step where I drag the link within Finder from where I created it to where I want it (into the MobileSync folder).
     

Share This Page