iPhone iPhone Baseband Will Not Upgrade

Discussion in 'Jailbreaks and iOS Hacks' started by degerus, Nov 3, 2012.

  1. degerus macrumors newbie

    Joined:
    Nov 3, 2012
    #1
    I have a iPhone 3G that refuses to update its baseband so that I can unlock it. It is currently on baseband 05.14.04. I've used redsn0w 9.15b3 with the option istall iPad baseband. I've tried using sn0wbreeze .. no luck. Does anybody have any suggestions or ideas about why this phone will not update to the iPad baseband? Below is some random information that I hope can be useful ..

    iPhone 3G
    iOS: 4.2.1
    Current Baseband: 05.14.04
    Bootloader: 6.4_M3S2

    hosts file entry: 74.208.10.249 gs.apple.com

    I am at a loss .. any help appreciated.
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Go to iClarified.com, they have a full tutorial for the bb downgrade procedure.
     
  3. degerus thread starter macrumors newbie

    Joined:
    Nov 3, 2012
    #3
    If that would work I wouldn't be posting here. I am completely frustrated as the baseband will absolutely not change from 05.15.04. I just need to get it unlocked. Here are some things I've tried.

    Used redsn0w 9.15b3 to install iPad baseband .. fail
    Used earlier version of redsn0w to install iPad baseband .. fail
    Used sn0wbreeze to generate custom ipsw with iPad baseband .. fails in iTunes restore (usb error) ... fail
    Downloaded iPad baseband to my pc and set hosts to fetch baseband from my pc ... fail
    Downgraded to 4.1 .. redsn0w, snowbreeze, etc .. all fail to upgrade baseband.
    Tried to downgrade baseband from redsn0w .. fail

    I have no idea what else to try to get this baseband to change. It won't go up or down. Anybody have any suggestions other than look at a tutorial? Thanks
     
  4. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #4
    just posting fail we can't help

    we need the exact error codes and steps you take to see where the problem is
     
  5. degerus thread starter macrumors newbie

    Joined:
    Nov 3, 2012
    #5
    Problem is I'm not really seeing any error codes. For example .. I can run redsn0w (any version) with the install ipad baseband option and although it never crashes or gives me an error code the baseband never gets updated on the phone. I've tried doing this in every way and every combination as I could imagine. I can jailbreak and hacktivate the phone, but, the baseband always remains at 05.15.04.

    For another example, if I create a custom ipsw with sn0wbreeze and tick the ipad baseband option, it seemingly successfully creates the ipsw. Kick into pwned DFU and use iTunes to restore .. now, at the end it will give me the recovery loop error, but, I can use tinyumbrella to exit recovery mode. After exiting recovery I can see that the new firmware has been applied, but, the baseband still remains at 05.15.04.

    After many tries, I decided that the when redsn0w was trying to download the iPad baseband it was doing so way to quickly. I thought, well, something must be preventing it from downloading. I set up AppServ and downloaded the iPad ipsw myself and then changed my hosts file so that when redsn0w was downloading it would just pull it directly from my computer. Still every time I use either redsn0w or sn0wbreeze the baseband remains at 05.15.04 ... even when the iPad files are being pulled directly from my pc.

    I am at a loss .. no idea why the baseband will not update. Anybody? Ideas?
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    The recovery loop indicates a BB error, which figures…

    Try a fresh install of 4.2.1

    Use redsn0w

    than use the iclarified tutorial
    http://www.iclarified.com/entry/index.php?enid=22652

    Make sure you only select the iPad BB no other options, don't install Cydia etc.

    It sometimes takes a multiple tries to get it in.
     
  7. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #7
    Use an older version of Redsn0w to flash the iPad baseband and do the downgrade.
    Run the downgrade as many times until it works.
     
  8. degerus thread starter macrumors newbie

    Joined:
    Nov 3, 2012
    #8
    Well, I finally got it to upgrade to the iPad baseband. Honestly, I don't know why it worked. But, here are some of the steps I took for anybody else who might encounter the same problem ...

    Deleted all traces of redsn0w/sn0wbreeze/tinyumbrella from registry,appdata,program files,etc.

    Uninstalled iTunes .. deleted all traces of iTunes from registry,appdata,program files,etc.

    Installed older version of iTunes (10.5)
    Redownloaded all ipsw files
    Downloaded several versions of redsn0w (redsn0w_win_0.9.11b4 worked for me)

    Restored to 4.2.1 from iTunes
    Ran redsn0w with option to upgrade baseband only, no cydia
    Phone got stuck at reboot on apple logo and i never saw the "flashing baseband" screen on the phone during first run
    Powered off (hold home and power for ~10 seconds)
    Unplugged phone from USB .. plugged into different USB port
    Put phone in DFU mode
    Ran redsn0w with option for cydia and ipad baseband
    During process finally saw "flashing baseband" screen on phone
    Phone rebooted, started normal and had the iPad baseband on it

    Ultimately I am not sure what the problem was. I must have tried 50 combinations of redsn0w/sn0wbreeze/iTunes/custom ipsws/etc. The above finally worked for me. Thanks for everybody's time in trying to help.
     
  9. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    Well changing iTunes, TinyUmbrella, Sn0wbreez had no effect
    Using the older Redsn0w is what made it work.
    This is a common recommendation for the issue you were having.

    Glad you got it done.
     
  10. rycyu macrumors newbie

    Joined:
    Mar 14, 2013
    #10
    thanks a lot,i just downloaded that redsn0w and flash ipad baseband and works,thanks again
     
  11. kinnarrk macrumors newbie

    Joined:
    Jul 20, 2013
    #11
    Thanks for the tip. redsn0w_win_0.9.11b4 worked for me as well.
     
  12. azeemfraz macrumors newbie

    Joined:
    Nov 17, 2013
    #12
    Updating baseband to 6.15

    Thanks, 9.11b4 worked for me as well.
     

Share This Page